Problem with booting after installing (linux-575, Debian 6.0.4 squeeze)

Asked by Felix Dekker on 2012-05-06

Yesterday I downloaded unetbootin-575-linux from Xubuntu, started it and selected to download the latest stable version (6.0.4 squeezy) through FTP. I rebooted the PC afterwards from the USB-drive and installed Debian without any problems.
But whenever I boot my PC without the presence of the earlier mentioned USB-drive I get a GRUB-error. I thought it was 'invalid operating system' or so. When I put in my USB-drive, press F12 to select the device to boot from and select my USB-drive Debian boots without any problem.
Logically I checked my USB-drive and found the files that were downloaded by unetbootin-575-linux. Should I move these files (ldlinux.sys, menu.c32, syslinux.cfg, ubninit, ubnkern) to the root of this PC? Or what should I do to make my PC 'independent'?

Question information

Language:
English Edit question
Status:
Solved
For:
UNetbootin Edit question
Assignee:
No assignee Edit question
Solved by:
Geza Kovacs
Solved:
2012-05-06
Last query:
2012-05-06
Last reply:
2012-05-06
Best Geza Kovacs (gezakovacs) said : #1

I think the problem is that grub got installed to your usb drive. Try booting, find out what device your hard drive is (for example, /dev/sda), then do, as root:

grub-install /dev/sda

Thanks Geza Kovacs, that solved my question.