unbuntu 12.4 and libpng12.so.0 no such file or directory

Asked by Andy

Complete noob here so sorry if I am wasting time, I have looked through these pages.

I have just installed ubuntu 12.4 and updated any packages that the updated said was needed.

I am trying to use unetbooting on said ubuntu system which I have downloaded from various sites the last from http://sourceforge.net/projects/unetbootin/files/UNetbootin/575/unetbootin-linux-575/download and then tried to run it after changing the setting in prefs.

I have also tried via the command line but both ways give me the same message -

./unetbootin-linux-latest: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

I have checked in software centre and have png library - runtime (libpng12-0) installed

Didn't know what else to do?

Thanks for any help in advance

Question information

English Edit question
UNetbootin Edit question
No assignee Edit question
Solved by:
Geza Kovacs
Last query:
Last reply:
Revision history for this message
Andy (k9sphericals) said :

Just tried adding libpng12-dev and libpng3 via synaptic package manager and still get the same message.

Revision history for this message
Best Geza Kovacs (gezakovacs) said :

Are you running 64-bit Ubuntu? Perhaps try installing ia32-libs.

Revision history for this message
Andy (k9sphericals) said :

This solved the problem

Cheers dude!