Device not working (firmware missing)

Asked by Red on 2011-04-12

I have a Dell Latitude D630 with a Dell Wireless 1490 Dual Band WLAN Mini-Card.

I have a hard drive in the laptop with Ubuntu 10.10 installed. When I boot Ubuntu from the hard drive, the WiFi works.

On another computer, running on Windows 7, I have downloaded UNetbootin-win-549.

Running UNetbootin, I start out with a newly formatted, 8GB, FAT32 thumb dirve.

I configure Unetbootin to use distribution Ubuntu/10.10_Live (also tried 10.04_Live, UNetbootin's default).

I also configured Space used for persistance: 2048

I get no errors running Unetbootin and I get no errors when I boot the Dell laptop from the thumb drive.

When I try to configure the WiFi network, I get "Device not working (firmware missing)"

Dell says that the dirvers for this WiFi have been included in Ubuntu since 8.10.

Question information

Language:
English Edit question
Status:
Solved
For:
UNetbootin Edit question
Assignee:
No assignee Edit question
Solved by:
Geza Kovacs
Solved:
2011-04-12
Last query:
2011-04-12
Last reply:
2011-04-12
Best Geza Kovacs (gezakovacs) said : #1

Since UNetbootin doesn't modify make any changes other than those related to booting (and Ubuntu appears to have booted correctly), this isn't an issue with UNetbootin, but rather with Ubuntu. Ask a question on Ubuntu http://answers.launchpad.net/ubuntu

Red (mabee) said : #2

I have to agree with that. With some additional testing, I also determined that the same is true for a Live CD.

But I did come up with the following:

With 10.10, if you wait long enough, an icon appears on the menubar to install drivers. Clicking on this icon displays a window labeled Hardware Drivers stating that the Broadcom STA wireless driver is not activated. Clicking on the Activate button causes Ubuntu to state that it is "downloading and installing" the driver. When this is finished, Ubuntu as states that "you need to restart the computer to activate this driver". However, you can now use the WiFi connection without restarting the computer.

This is also true with 10.04, but the Hardware Drivers window lists a Broadcom B43 wireless driver also. Trying to activate this driver fails but does not affect the activation of the Broadcom STA wireless driver.

I am about to test 11.04.