Universal Netboot Installer

Why has the "Show all drives" option been removed?

Asked by MasterNetra on 2011-04-04

I was wondering why it was removed, and could you please restore the show all drives option, I need it for NTFS partitioned devices... I keep a backup of my Windows Restore DVD on it (requires a NTFS partition) and sometimes I have to transfer data using the USB drive, as such I have to occasionally wipe it and put it back on later. So please put that option back on Unetbootin.

*Updated Question with the proper name of option*

Question information

Language:
English Edit question
Status:
Answered
For:
UNetbootin Edit question
Assignee:
No assignee Edit question
Last query:
2011-04-04
Last reply:
2012-08-25
MasterNetra (designerkline) said : #1

Also note, I don't currently have a DVD+RW drive thus the need for the USB.

MasterNetra (designerkline) said : #2

Correction - its "Show all Drives" I'm referring to.

Geza Kovacs (gezakovacs) said : #3

If your external device is formatted as anything other than FAT32, then UNetbootin isn't installing the bootloader onto it. You would have gotten the same effect simply by using 7-zip, WinRAR, or any other archive manager to extract the contents of the iso file to the drive. The option was removed precisely for this reason (and to prevent users from making their existing operating system unbootable if they selected the wrong drive when the "Show All Drives" option was checked).

I have a SD card, it's formatted in FAT32 and without this option I cannot use it with UNetbootin.

Tiago Faria (gouki) said : #5

This question is not answered. Added Information Request.

abrsdk (abrsdk) said : #6

I faced the same problem, i needed to put my backup windows 7 copy o a usb drive, but when the drive is formatted as fat32, windows wont boot. The only way to boot windows successfully using unetbootin is to use an ntfs formatted drive, which current unetbootin version don't seem to support, and because the "show all drives" option was missing, i couldn't make a custom selection. so i had to go back and use an older version of unetbootin to get the job done. the last stable version with show all drive option was unetbootin-linux-506. using that will help people who are facing the same problem like me for now. but i really don't think it was necessary to remove that option. http://sourceforge.net/projects/unetbootin/files/UNetbootin/506/

crysys (jbitterly) said : #7

I have an external USB hard drive with two fat32 partitions that I wanted to use unetbootin to load iso images on and make bootable. These partitions would not show up in the menu and I had to use an older version with the 'Show all drives' option to select these partitions. Could the show all drives check box box at least be available after passing a cli argument? ie: 'unetbootin --all_drives' It seems this would still shield the regular users and allow those who know what they are doing to continue.

I'm not entirely sure why unetbootin would not allow me to select the partitions in the first place. They were both formatted fat32, but there is a third NTFS partition on the drive.

I first tried the latest windows release, and eventually used the older ubuntu custom release, unetbootin-ubuntu-customsfx-windows-248.exe This was on a Windows 7 x64 machine.

Carl Bullock (dreamsofubuntu) said : #8

I'm also wondering why this option was removed, I've rarely been able to get Unetbbootin to find a multitude of my devices (USB Drive, SDCards etc.) I often have to resort to using an older version unetbootin to use this feature...

Reset (r3s3t-osfight) said : #9

As far as I do understand it: Format your usb drive using NTFS and simply extract the Windows ISO image onto the hard drive and it will work. There is no need to use Unetbootin. For all other OSes, format the USB drive with with FAT32 and Unetbootin will detect the USB drive properly.

Reset (r3s3t-osfight) said : #10

So in summary: The missing option "Show all Devices" is not a bug but a "feature" since you do not need it anyway. However, I am not sure if this is true in all cases.

Iwan Gabovitch (qubodup) said : #11

Where is the answer to this question?

I have a system with 3 hard disks and no usb drive and I want to use one of the hard drives to install unetbootin. Two of them are not mounted.

All I see is "/" under Hard Drives.

Gonna go pick up an old version.

patryk (pbratkowski) said : #12

While I guess it is a design decision and not a bug per se, it is a poor decision IMO.

For some reason, when I format my USB key in FAT32, Unetbootin does not list it. It only works with an ext{2,3,4} partition.

Using Ubuntu 10.04 LTS with Unetbootin 555 from GetDeb.

Luckily I have Windows XP running in Virtualbox, that might work with a FAT32 key.

Shakan (m-schakohl) said : #13

I also need the "Show all Drives" option. Not one of my USB devices is recognised by Unetbooin.
They are FAT32 but it just doesn't work.
On my old ubuntu installation the removed option was a great help.
I don't understand why removing features is so trendy.

I Hate Logins (joako) said : #14

I am using Windows 7 64 bit and I am attempting to create a bootable USB drive with VMWare ESXi 4.1. I ran this in MacOS and the drive is detected, however nothing produces a bootable drive so I moved to trying the same steps in Windows (they say stupidity is trying the same thing over and expecting different results) however in Windows unetbootin only shows c:\ and not my USB drive. I have tried to format it it on MacOS and Windows as FAT and FAT32. I didn't even try NTFS because it's not supposed to work.

I search for the "answer" which appears to be this option that has been removed because the developers think I am too stupid... but c:\ is shown as the only destination drive?

So please let the users pick what they want. If the user is too stupid to pick the correct option then maybe they will learn next time to research it and come to the correct conclusion and our society as a whole can work together towards IMPROVING.

Bryan Bonvallet (btbonval) said : #15

I also found the lack of a "Show all Drives" selection to be a problem. But there is a bigger problem if one is using the command line options: setting "targetdrive=blah" where blah is not a valid option in the dropdown will simply select a different targetdrive.

This is downright dangerous if one doesn't look closely! If they are removing features to prevent people from making dumb mistakes, I would highly recommend a consistent approach: when the targetdrive commandline option is invalid, please exit with an error instead of changing the selection!

Further, commandline options are typically used by the type of people who enjoy shooting themselves in the feet. Why not let the targetdrive option be unrestricted? The mere presence of the option could act as though "Show all Drives" is in effect (for the chosen device at any rate).

I am attempting to install a CD-bootable ISO into a loopback device to create a new ISO that will properly chainload from GRUB; I use Unetbootin ISOs + GRUB for cleanly segregated multiboot on a thumb drive. For people looking for a tutorial: nevermind, unetbootin doesn't allow it anymore!

I don't see "format with FAT32" as a viable fix. I have formatted the loopback partition as FAT32 (mkfs.msdos -F 32 /dev/loop0), mounted it, and Unetbootin still ignores it like it was never there. The answer given is thus unacceptable, as FAT32 is clearly not working in some use cases.

In regards to the previous poster, I too have had problems caused by this feature. Because of this, Unetbootin decided to map the four partitions on my main HDD instead and I unwittingly wrote Ubuntu to the EFI partition on my drive. Pretty dangerous. I too am having problems getting a correctly mapped and partitioned FAT32 drive to be detected.

Geza Kovacs (gezakovacs) said : #17

@Seamus, Bryan: as of the 578 release https://sourceforge.net/projects/unetbootin/files/UNetbootin/578/ the targetdrive=/dev/something option will allow you to specify any drive as the target (albeit it won't do any checking or provide warnings if you provide it with invalid input, so use with care). I'm working on UI-level changes to accommodate the use case of installing to an external hard drive partition formatted as FAT32; the other targets mentioned (NTFS-formatted partitions or hard drives using EFI instead of MBR) would not boot anyway (syslinux doesn't support them) so they won't be available via the UI.

Bryan Bonvallet (btbonval) said : #18

The CLI option is much appreciated. Shooting myself in the foot is a favorite pasttime.

I had to switch to an older version that doesn't have such checks (as suggested somewhere above), so I don't know what I've been missing in newer versions. I look forward to trying it out!

Thanks.

Carlo Wood (carlo-alinoe) said : #19

SOLVED

After two days of reading and trying, I have come to the following conclusion:
To boot windows 7 from USB stick you (indeed) do NOT need unetbootin for
exactly the reason as is stated at the top.

What you DO need is: An USB Flash Drive (UFD) that is formatted as ntfs,
then simply copy the files from the iso to it.

I used the following linux-only commands and successfully installed
windows with it:

sux # Like su, but gives access to X GUI.
gparted
<remove partition table>
<add one primary partition>
<format as ntfs, apply>
<manage flags, set 'boot' flag on partition>
<exit gparted>
exit # Leave sux

su
mkfs -t ntfs /dev/sdX (replace with the your USB device)
mkdir /mnt/ufd
mount -t ntfs /dev/sdX /mnt/ufd
mkdir /mnt/dvd
mount -r -o loop X17-58997.iso /mnt/dvd

tar -C /mnt/dvd -c -f - . | tar -C /mnt/ufd -x -v -f -
umount /mnt/ufd
<remove USB stick, put it back again>
mount -t ntfs /dev/sdX /mnt/ufd
tar -C /mnt/dvd -c -f - . | tar -C /mnt/ufd -d -f - | egrep -v '(Mode|Uid|Gid) differs'
<no output = copy to UFD successful>
umount /mnt/ufd
umount /mnt/dvd
<remove USB stick>

Note that next you probably want to select an empty disk
(no partition table) and have that FIRST in boot order, and
the flash drive second. That way it will boot from USB the
first time and from the selected HDD that you install windows
to the second and subsequent times during the install of
windows (if it boots again from the USB the whole install
just starts from the beginning; if that happens just reboot
again and change boot order to boot from the selected
HDD).

Carlo Wood (carlo-alinoe) said : #20

I replaced /dev/sda1 with /dev/sdX in the hope people who have a HDD on sda instead of their USB wouldn't copy&paste it and erase their harddisk. However it is a bit confusing :p. Of course, everywhere you should use /dev/sdX1. Unfortunately, I can't edit my post. Also, the give format fill the partition with zeroes and does a bad blocks test, that is hardly necessary. A better, and sufficient, way to format the USB decive is: mkfs.ntfs --quick /dev/sdX1. Finally I'd like to remark that the choice of ufd above might not have been the best choice. Often udf (Universal Disk Format) is used for USB disk, too. The name doesn't really matter of course, but this way it looks like a mix up of things :p.

Can you help with this problem?

Provide an answer of your own, or ask MasterNetra for more information if necessary.

To post a message you must log in.