Installation of 10.10 : alternate iso installer insists on CD drive

Asked by Andy Phillips on 2010-12-05

Hi guys and gals,

After reading around the web and the online documentation I've failed to find a solution to my problem. I'm really hoping you can point me in the right direction...

I have a Samsung N130 with Windows XP, 1GB RAM and a 160 GB hard disc. I have downloaded the main ISO for 10.10 desktop and used the windows utility to burn an installation disc onto a 4GB USB memory stick. I set the stick to be formatted and persistent. I have also amended the boot sequence of the netbook

When rebooting the machine it prompts me to take a number of options including memory test, install direct to HD and run Ubuntu. The memory test was passed but no matter which of the other options I choose the installation hangs. I am presented with the first screen summarizing what is present (Internet, power etc) and letting me select the language and additional downloads

I am on mains power, connected OK to the Internet and have opted for English language. I have opted not to download updates or MP3 extras at this time. I click the forwards button and the screen doesn't change. I get the swirly busy icon but nothing else. I have left it running for three hours like this to ensure I wasn't being impatient! Oddly, if I select cancel then the installer responds instantly...

Before I slope off back to Windows does anybody have any ideas how to diagnose this hiccup further? I'm running in the full GUI mode because that's the only option presented to me. Unfortunately it does seem I can't see what problem has occurred :)

Thanks in advance,

Andy

Question information

Language:
English Edit question
Status:
Solved
For:
UNetbootin Edit question
Assignee:
No assignee Edit question
Solved by:
Andy Phillips
Solved:
2010-12-22
Last query:
2010-12-22
Last reply:
2010-12-12

Did you MD5 test the ISO you downloaded? What app did you use to transfer Ubuntu to the uSB device?

Andy Phillips (thestoat) said : #2

Hi and thanks for coming back to me. Yep, I md5 tested the ISO and it came up with this:

59d15a16ce90c8ee97fa7c211b7673a8

I used the recommended utility from the Ubuntu.net download page to create the bootable stick. The link it gives is:

http://www.pendrivelinux.com/downloads/Universal-USB-Installer/Universal-USB-Installer.exe

Hope that helps,

Andy

delance (olivier-delance) said : #3

59d15a16ce90c8ee97fa7c211b7673a8 ubuntu-10.10-desktop-i386.iso It looks good.
I have not lot of ideas.
1-Boot and choose "Try without install", then System->Administration->Test System and check hardware management.
2-Could you try to install without Internet (both unplug network and ask at screen no network) ?

Andy Phillips (thestoat) said : #4

Hi,

Have tried with networking disabled and the same things happens - the installer hangs after the downloads and summary screen

On the hardware test I have some interesting results and will hopefully post up the report in the next few seconds

Thanks,

Andy

Andy Phillips (thestoat) said : #5

Nope, that didn't work! I specified my launchpad email address to submit the hardware report but I have no idea where to find it now... Anybody have any idea how to retrieve the hardware report or upload it again?

Andy Phillips (thestoat) said : #6

Ok, I have re-run the hardware checker and the only failure is on the desktop display resolution. Apparently my netbook doesn't cut the mustard. However that's not going to be the reason the installation hangs :-(

Is there perhaps a log file for the installation process?

Thanks,

Andy

delance (olivier-delance) said : #7

Log files are usually in /var/log in hard disk.
You will have to boot with "Try without install", mount hard disk and search inside folder of hard disk a folder named "var", then "log".

Andy Phillips (thestoat) said : #8

Thanks for that but I don't see any /var/log on either of the partitions on the hard disc. If it helps both discs are seen by the places application and the hardware checker so my guess is the installer application isn't being held up by that detection process

Now I can find a /var/log on the USB stick. Would this be the right place to find an installation log file? There is a subdirectory "installer" but this only contains two embryonic log files with no useful data

Does the lack of file logging in the usual place narrow down the issue for you?

Andy

Andy Phillips (thestoat) said : #9

Just to clarify (and probably something I should have posted at the beginning!) here is a picture of the screen I get stuck on. Sorry for the quality but Photobucket wouldn't upload it directly for some reason so here it is via my mobile (!)...

http://i1184.photobucket.com/albums/z338/Thestoat/344dc0ec.jpg?t=1291577923

Hopefully we're been talking about the same screen all along and therefore the same part of the installation process

Thanks,

Andy

delance (olivier-delance) said : #10

First time I see this issue:
   you have a laptop
   you are plugged to main power
   installation software say you are only on battery
so installation software refuses to start!

As I have no laptop, it's not easy for me to test.

1-Could you check again laptop is well connected to main power (I presume you did) ?
2-Could you try with: http://www.ubuntu.com/desktop/get-ubuntu/alternative-download#alternate
Perhaps this version doesn't check main power.

Andy Phillips (thestoat) said : #11

Hi,

Nope that's just a red herring I'm afraid. I have tried the installation while on mains power and the installer detects the main power correctly. The snapshot I posted was just to indicate the screen on which the installer hangs. It still hangs even when on mains power and the mains power is detected :-(

Thanks,

Andy

Andy Phillips (thestoat) said : #12

Any other suggestions guys? I'mreally struggling here without any debug information. Does anybody have a way to run the installer in some sort of verbose mode?

Thanks,

Andy

Netz V (gaberth) said : #13

Well something courios happends with Windows XP or older versions when you try to install on new computers, in the BIOS check th Type of Hard Disk device i cant install older or Ubuntu after i changed, check the different options SATA, IDE, EIDE, choose the most simple device type to "un-protect" the Hard Drive, dont worry nothing happends with Windows Installation

Netz

Andy Phillips (thestoat) said : #14

Hi,

Thanks for the suggestion but hard drive protection is already disabled and there is no way to force the BIOS to treat the hard disc as a particular type. It just auto-detects

Thanks,

Andy

delance (olivier-delance) said : #15

Does anybody have a way to run the installer in some sort of verbose mode?
   2-Could you try with: http://www.ubuntu.com/desktop/get-ubuntu/alternative-download#alternate

Andy Phillips (thestoat) said : #16

Phew! Sorry for the delay in getting back to you guys but after LOADS of installer and Internet problems I now have a working bootable USB stick again. I have followed the steps on the alternative installer menus and it grinds to a halt trying to mount the CD drive. Being a netbook there isn't a CD drive and never has been. The installation process treats this as a fatal error and asks me to locate the device file i.e. /dev/cdrom

I can't get past this stage. How did anybody else get through this step? I've got a hard disc and a USB stick and that's it...

Thanks for any advice,

Andy

Andy Phillips (thestoat) said : #17

Just one final thought - is there a device file I could specify in lieu of the CD drive file that would point the installer to the USB stick? Or would that cause more problems?

Thanks,

Andy

delance (olivier-delance) said : #18

"it grinds to a halt trying to mount the CD drive"
For what I understand, the ISO image is put directly into USB key, and at boot this image is mounted in a virtual CD driver. This explains what you get an error message about /dev/cdrom, which in fact is virtual.
Did you MD5 checked the new ISO image (alternative distro) ?

Andy Phillips (thestoat) said : #19

Hiya,

Finally managed to check the MD5 again after *somebody* deleted the downloaded iso file - twice! It matches and reports the following checksum:

419ad8ee1bb76a49490f4a08b5be43f0

Unfortunately I still get stuck at the same point - the installer is asking for the device to be used for the CD drive :-( Help!

I go through the prompt to install, select the language and keyboard ok but then the CD drive detection fails and the installer asks me if I want to install drivers from removable media. I select no because I don't have a CD drive or drivers. I then get a prompt to manually select the "CD-ROM module and device". If I answer no the installation halts but I don't know what device to select to use to continue using the USB stick...

Thanks,

Andy

Try using unetbootin to put the ISO on the USB
http://unetbootin.sourceforge.net/unetbootin-windows-latest.exe

Andy Phillips (thestoat) said : #21

OK, will give that a go. Have been using the installer recommended on the downloads page of the Ubuntu site so far. Fingers crossed for this one :-)

Andy Phillips (thestoat) said : #22

OK, will give that a go. Have been using the installer recommended on the downloads page of the Ubuntu site so far. Fingers crossed for this one :-)

Andy Phillips (thestoat) said : #23

Nope, that had exactly the same effect I'm afraid. It just fails to detect any CD drive and then obsesses over it. Does anybody know how to persuade the installer that all the files it needs are on the USB stick? The option I chose by the way was Install Ubuntu. There were a few other options on the initial menu but I wasn't really sure how to proceed with the Command Line Expert option!

Thanks,

Andy

Have you tried a different USB device, the common item here is the USB you are using (unless you have tried a different media and not let us know)

Andy Phillips (thestoat) said : #25

Nope but the USB device is brand new and mounts correctly on multiple machines and verifies ok too

delance (olivier-delance) said : #26

Move to project Unetbootin to warn packet's subscribers of issue.

Andy Phillips (thestoat) said : #27

Hey guys,

Any news on this issue? Anything else I can try or a log file I can generate for you?

Thanks,

Andy

Andy Phillips (thestoat) said : #28

Hi guys,

I seem to have got to the bottom of this issue by trial and error. It seems that the standard desktop install iso installer doesn't work on a standard Samsung N130 netbook for some unknown reason. However I was able to start Ubuntu in trial mode fromthe USB stick. At that point the USB installation was running in persistent mode and I was able to install updates via the software manager. Some 200 MB later the installer magically works and I now have Ubuntu running on my netbook. Sorry I can't be more specific than that but as I say - trial and error!

Thanks for all your suggestions and hopefully this thread will help other if not resolve a bug then maybe sidestep it as I did. Just got to get my mouse working now...

Cheers,

Andy