please add support for kaspersky latest rescue disk,old one work new one does not

Asked by max on 2010-05-16

hello
i been a fan of unetbootin from very long time
this is such genius tool that with its help i helped a lot of people to make usb kaspersky rescue disk
all of them were tiered after trying many solution and posting in the forum of kaspersky about failure in booting
then i started posting about this tool there and it helped every one

but this tool does now longer do the charm for the latest version of kaspersky rescue disk
it give a lot of error etc

so i would like to request the developers to please help and include the support and fix for the latest rescue disk
link to rescue disk here ftp://devbuilds.kaspersky-labs.com/devbuilds/RescueDisk10/

please do reply
thanks for such a magical utility

Question information

Language:
English Edit question
Status:
Answered
For:
UNetbootin Edit question
Assignee:
Geza Kovacs Edit question
Last query:
2010-05-16
Last reply:
2010-07-24
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Geza Kovacs (gezakovacs) said : #2

KRD10 currently doesn't work since it uses GRUB2, which I haven't yet implemented config file parsing for. I'm planning on doing so soon.

Geza Kovacs (gezakovacs) said : #3

I've implemented GRUB2 config file parsing as of the latest commit (455), but unfortunately Kaspersky Rescue Disk 10 is apparently unable to detect my USB drive, and is failing with the following message:

>> Activating mdev
>> Making tmpfs for /newroot
>> Trying to mount live usb...
>> Looking for the cdrom
>> Attempting to mount media:- /dev/sda1
>> Attempting to mount media:- /dev/sdb1
>> Attempting to mount media:- /dev/sdc
!! Media not found
>> No bootable medium found. Waiting for new devices...
>> Looking for the cdrom
>> Attempting to mount media:- /dev/sda1
>> Attempting to mount media:- /dev/sdb1
>> Attempting to mount media:- /dev/sdc
!! Media not found
!! Could not find CD to boot, something else needed!
>> Determining root device...
!! Could not find the root block device in .
    Please specify another value or: press Enter for the same, type "shell" for a shell, or "q" to skip...
root block device():: /dev/sdb1
>> Mounting root...
!! The filesystem mounted at /dev/sdb1 does not appear to be avalid /, try again
!! Could not find the root block device in .
    Please specify another value or: press Enter for the same, type "shell" for a shell, or "q" to skip...
root block device()::

When I drop into the shell, I am able to mount /dev/sdb1 and can see that image.squashfs and the rest of the files are there, so the issue doesn't appear to be that it's unable to detect or mount my USB drive, rather that it's not recognizing it as the boot device.

I am using the following boot options:

kernel /boot/rescue
append initrd=/boot/rescue.igz root=/dev/ram0 init=/linuxrc looptype=squashfs loop=/image.squashfs cdroot noapic kav_lang=en quiet

Geza Kovacs (gezakovacs) said : #4

As of the current release (466), Kaspersky Rescue Disk 10 should now be working. Please test.

max (hottt-maxxx) said : #5

sorry for responding late
i am extremely happy that you listen to my question
and worked hard and spent your lots of valuable time to fix it

i will be testing it today and will reply you soon

thanks man really very very thank you

lst (lukshuntim) said : #6

I tried the same with unetbootin (version 471) in debian/sid but when the USB harddisk boots, I got a "Missing operation system" error message.

Any help would be very much appreciated.

max (hottt-maxxx) said : #7

on my end its perfectly working fine
may be Geza Kovacs could help you

Geza Kovacs (gezakovacs) said : #8

@lukshuntim That sounds like your USB harddisk wasn't made bootable; make sure it's FAT32 formatted, and make sure you're using the USB drive (not Hard Disk) install option as it's an external drive. Anyhow that is a different issue from this one (it's not specific to Kaspersky Rescue Disk), so open a new question if you continue to have issues.

lst (lukshuntim) said : #9

On 07/23/2010 02:23 PM, Geza Kovacs wrote:
> Question #111259 on UNetbootin changed:
> https://answers.edge.launchpad.net/unetbootin/+question/111259
>
> Geza Kovacs proposed the following answer:
> @lukshuntim That sounds like your USB harddisk wasn't made bootable;
> make sure it's FAT32 formatted, and make sure you're using the USB drive
> (not Hard Disk) install option as it's an external drive. Anyhow that is
> a different issue from this one (it's not specific to Kaspersky Rescue
> Disk), so open a new question if you continue to have issues.
>

Hi Geza,

Yes, it's quite strange as I'm using an old USB disk that's already
bootable and has a vfat 1st partition. Based on your tip, I used parted
to delete the partition, create it again, toggle the boot flag on, and
somehow it work this time!

Thanks very much for your answer. Thanks to max too.
ST
--

Can you help with this problem?

Provide an answer of your own, or ask max for more information if necessary.

To post a message you must log in.