Save Position doesn't seem to work

Asked by Liam Philpott on 2015-08-07

Hi - thanks for the great app. I just noticed that the Save Position functionality doesn't seem to work for me. I'm running unav version 0.22 on a BQ Aquaris E4.5 with OTA-5 (Ubuntu 15.04 r8).

With the map visible and my current location showing with the blue arrow: when I click on the "Set/Change the route" icon, a menu pops up showing the options: "Favourites", "Go Gas Station", "Save Position" and "Cancel Route".

If I click "Save Position" it says I can "Save the current position with a name". So I give it a name and press the "Enter" button on the virtual keyboard. It then goes back to the map.

If I click the "Set/Change the route" icon again and then select "Favourites" there are no places listed. Am I doing something wrong here?

Question information

Language:
English Edit question
Status:
Solved
For:
uNav Edit question
Assignee:
No assignee Edit question
Solved by:
costales
Solved:
2015-08-13
Last query:
2015-08-13
Last reply:
2015-08-13
costales (costales) said : #1

Hi! Thanks a lot for the feedback.
Maybe there is a bug. Could you tell me the name you put for the
destination?

--
Sent using Dekko from my Ubuntu device

I used "Work" as the place name, but it didn't save it. Thanks for the quick response.

costales (costales) said : #3

Did you change of application? Could you try it again and wait a few
minutes?

--
Sent using Dekko from my Ubuntu device

Hi. Thanks for the reply. I checked for software updates, but unav didn't update. I'm still running version 0.22. I tried to save my location again now, but it still does not work. When I go in to Favourites it still says "No favourites yet".

costales (costales) said : #5

uhm... i tried and it is working right for me.
there is a device bug about to a real favorite save, but if you didn't send
unav to the background you have to see it.
More users, please, could you give your feedback about this? thanks :)

--
Sent using Dekko from my Ubuntu device

costales (costales) said : #6

I think you have this problem:
https://bugs.launchpad.net/ubuntu/+source/oxide-qt/+bug/1469487
I have your same phone and is working right :O Could you try again please?

costales (costales) said : #7

I was reading again...

> So I give it a name and press the "Enter" button on the virtual keyboard. It then goes back to the map.

In the 0.22, it should be:
1. give it a name
2. press the "Enter" button
3. Press Back.

And the bookmark should be again in there (unless you kill the app or you send it to background).

Hi. Thanks again for the reply.

I tried this but it still didn't work.

1. I gave the location a name.
2. I pressed Enter on the virtual keyboard.
3. It goes straight back to the map - so there is no back button at that point.

If I just press the back button before pressing Enter, it does not save it either. At no time did I kill the app or move it to the background. Apologies if I'm doing something wrong here. Nobody else seems to have confirmed this so maybe I'm just doing something wrong.

Best costales (costales) said : #9

Probably near plans will change this behavior, then it will be fixed in
future release (~2 months?).

Okay, great. Thanks for all your help.

Just to let you know: the 0.23 update to unav from August 29th fixed this problem. I am now able to save favourites on my BQ Aquaris E4.5 and the navigation is working fine. Thanks for all your work.

costales (costales) said : #12

Yes :) Now we're storing the favorites with another method and works as it
should be.
Thanks for your feedaback Liam :)) It was really appreciated!