Delete all Tomboy Notes in Ubuntu One (Reset)

Asked by Klaus Franken

I have chaos and confusion with my tomboy Notes. Does a easy way exist to reset the Notes and start new. I delete all notes from my pc but the notes on Ubuntu One Server still exists. Is there only the possibilty to delete all notes separate.

Many Greetings from germany Klaus (I am sorry, my english is not so good)

20 minutes later : Now my old Notes are deleted and synchronisied with my latest notes, I do not know why. But my problem is resolved.

Question information

English Edit question
Ubuntu One Servers Edit question
No assignee Edit question
Solved by:
Joshua Hoover
Last query:
Last reply:
Revision history for this message
Best Joshua Hoover (joshuahoover) said :

Hi Klaus,

One way to delete all the notes on the server right now is to delete each individual note. If you have a lot of notes, you can try doing it this way:

  1. Quit Tomboy
  2. Open a terminal session (Applications->Accessories->Terminal) and run:
      cp -r ~/.local/share/tomboy ~/Desktop/
      rm -r ~/.local/share/tomboy
  3. Open Tomboy (all the notes should be gone)
  4. Synchronize notes: Tools->Synchronize Notes
  5. Check the web site to make sure all the notes are gone: https;//
  6. Quit Tomboy
  7. In the terminal session run:
      cp -r ~/Desktop/tomboy ~/.local/share/
  8. Open Tomboy (all your notes should be back)
  9. Synchronize notes: Tools->Synchronize Notes
10. Check the web site to make sure all the notes are there: https;//

Thank you,


Revision history for this message
Klaus Franken (kl-franken) said :

Thanks for your reply and your clear instructions.

I am not sure, why it did not work with my first attempts. Yesterday I marked all entries in tomboy and delete this entries. After sync my "ubuntu one notes" were clean, all notes are vanished. Then I did a new set up and copied my saved Tomboy folder under local/share/.

Revision history for this message
Paolo Milani (j-s-sebastian) said :

This does not work for me, because when I do step 9, synchronization tells me it is downloading changes from the server and deletes most of my notes. I think the root of the problem is that, even if your notes section on the website looks empty, ubuntu one remembers that it has to delete notes, and there is no "reset" button to make it start completely anew. The same kind of thing happens with tomboy when using ssh sync or local folder sync (i've tried all sorts of combinations), but I think you can work around it by starting local folder sync from scratch on a new local folder. The ubuntu one equivalent of this workaround, in the absence of a "reset" button, might be to create a new ubuntu one account and start from scratch. I also tried copying the notes that were deleted by the sync back into .local/share/tomboy. This way they don't get deleted again in the next sync, but most of them don't get synched back to the server either.

For now I am switching back to local folder sync + dropbox (which means no sync to my n900 phone).

Revision history for this message
Giacomo (poderi1980) said :

It does not work for me either.

After cleaning local folder, and trying to sync to clean the server (step 4), it happens that all the old notes from the server get downloaded again in my local folder.

Is there another way to clean the U1 server from the notes? I have hundreds of clicking "delete" on each of them in U1 is no solution.

Revision history for this message
Davim (davim) said :

Same problem here...

Revision history for this message
Roman Yepishev (rye) said :

To delete the notes completely the following needs to be done:
Please note that database removal cannot be undone.

On all machines that are attached to your ubuntuone account:
 1. Download the script from
 2. Run it as "python --drop notes"
This will remove the local copy of the notes database.

On one of the machines that are attached to your ubuntuone account:
 1. Download the script from
 2. Run it as "python ubuntuone-couchdb-query --http-method=DELETE notes"
This will remove the server-side version of the notes database.

Visit and verify that all notes are gone.

It is necessary to remove all local notes databases too because the replication will recreate the missing databases unless all copies are destroyed.

Revision history for this message
Ingo Gerth (igerth) said :

Roman, the last procedure does not work and gives the following output. Any ideas why? I'm desperate that my syncing doesn't work anymore..........

ingo@Ingos-Elitebook:~$ cd /tmp
ingo@Ingos-Elitebook:/tmp$ wget
--2011-10-18 18:56:07--
Connecting to||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10469 (10K) [text/plain]
Saving to: `ubuntuone-couchdb-query'

100%[======================================>] 10.469 --.-K/s in 0,08s

2011-10-18 18:56:08 (127 KB/s) - `ubuntuone-couchdb-query' saved [10469/10469]

ingo@Ingos-Elitebook:/tmp$ python ubuntuone-couchdb-query --http-method=DELETE notes
Traceback (most recent call last):
  File "ubuntuone-couchdb-query", line 269, in <module>[0], options)
  File "ubuntuone-couchdb-query", line 148, in run
    self.main(url, options)
  File "ubuntuone-couchdb-query", line 153, in main
    show_tokens=options.show_tokens, show_account=options.show_account)
  File "ubuntuone-couchdb-query", line 207, in request
    " %r" % (resp['status'], content))
Exception: There was a problem processing the request:
status:503, response: '<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">\n<html><head>\n<title>503 Service Temporarily Unavailable</title>\n</head><body>\n<h1>Service Temporarily Unavailable</h1>\n<p>The server is temporarily unable to service your\nrequest due to maintenance downtime or capacity\nproblems. Please try again later.</p>\n<hr>\n<address>Apache/2.2.14 (Ubuntu) Server at Port 443</address>\n</body></html>\n'

Revision history for this message
Ingo Gerth (igerth) said :

I linked my bug because it is related to this issue.