Why has bug #391600 been changed to invalid?

Asked by alpha1 on 2009-10-23

Bug #391600: Could not install ubuntuone-client under kubuntu

The status was changed to "Invalid" by Joshua Hoover. Whether it is a bug or error in documentation seems to make little difference to someone unable to install it. Also, it is listed as low priority. I believe that it should be high priority, as there seems to be quite a few people who are unable to install ubuntuone in kubuntu.

I tried to follow the instructions given at
      https://answers.edge.launchpad.net/ubuntuone-client/+faq/594

First, the "Install" button in Firefox doesn't work. Someone else reported that problem and the only reply was "do you have apturl installed?" I do have it installed.

Like others, after running $ sudo gdebi ubuntuone-jaunty-ppa.deb
Synaptic does not find ubuntuone.

Michael Schunk wrote:
you should have:
    http://ppa.launchpad.net/ubuntuone/beta/ubuntu
in your list.

I do have http://ppa.launchpad.net/ubuntuone/beta/ubuntu jaunty main
and http://ppa.launchpad.net/ubuntuone/beta/ubuntu jaunty main (Source Code)
in my repository, but still no ubuntuone in quick search.

I was a bit confused by the following steps in the instructions:
4) Run: $ sudo gdebi ubuntuone-jaunty-ppa.deb
6) Install the PPA
  -- does step 4 Install the PPA? Is there a step 5) missing? If step 4 does not install the PPA, how is that done?

I tried reloading in Synaptic several times without any change in the situation.

It seems that some people have had success, but in trying to duplicate what they reported, I had no such luck.

I would appreciate the advice of anyone who has had similar problems installing this in Kubuntu 9.04, and solved them.

Thanks.

Question information

Joshua Hoover (joshuahoover) said : #1

My apologies for the unclear instructions. I have just updated them in the FAQ and hope this resolves the problems you were having. Instead of using Synaptic, I've changed the instructions to install from the command line as there is a known issue with Synaptic in not showing some packages from 3rd party PPAs.

Joshua Hoover (joshuahoover) said : #2

Joshua Hoover suggests this article as an answer to your question:
FAQ #594: “How do I install the Ubuntu One client software on Kubuntu?”.

alpha1 (wmstrome) said : #3

When I tried the new instructions, I got the following message at the end of the
sudo apt-get update && sudo apt-get install ubuntuone*
attempt.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
  python-ubuntuone-storageprotocol: Conflicts: ubuntuone-storage-protocol but 0.90.2+r45-0ubuntu1~ppa1~jaunty is to be installed
  ubuntuone-ppa-beta: Conflicts: ubuntuone-ppa but 2009.04.27-0ubuntu1 is to be installed
E: Broken packages

Where do I go from here?

Jonathan Jesse (jjesse) said : #4

Created this blog post yesterday which was pushed out to Planet Ubuntu: http://jjesse.wordpress.com/2009/10/26/installing-ubuntu-one-on-kubuntu-9-10/

THis is for using Kubuntu 9.10 and getting it to work correctly.

Hope it helps

alpha1 (wmstrome) said : #5

Since I don't have Kubuntu 9.10 yet, it doesn't help much. I am not sure that I have enough space on my eeePC notebook to install all of that Gnome stuff!

Joshua Hoover (joshuahoover) said : #6

It sounds like you may have some old packages there, maybe? If you try this, can you let me know what you find:

sudo apt-get purge ubuntuone*
sudo apt-get autoclean
sudo apt-get update && sudo apt-get upgrade

Thank you,

Joshua

alpha1 (wmstrome) said : #7

It did clean out some old stuff. I guess I should try again to install it using the instructions at:
https://answers.edge.launchpad.net/ubuntuone-client/+faq/594

Thanks.

Murray

Joshua Hoover (joshuahoover) said : #8

Hi Murray,

Any luck with getting Ubuntu One installed?

Thank you,

Joshua

alpha1 (wmstrome) said : #9

No, not yet. I have just tried upgrading to 9.10 on one computer and I may try again there. It is interesting to me that Dropbox appears to be a similar application, and it too is designed for Gnome, not KDE. Nevertheless, I was able to get it to install and work properly in Kubuntu, and after the upgrade, it continues to work well in 9.10 (release candidate).

I will be travelling over the weekend, so may not get back to it until Monday.

Thanks

alpha1 (wmstrome) said : #10

OK I did try it again using the https://answers.edge.launchpad.net/ubuntuone-client/+faq/594
The step Run: $ sudo gdebi ubuntuone-jaunty-ppa.deb seemed to work OK, but when I tried "sudo apt-get update && sudo apt-get install ubuntuone*" I got the following error:
E: Couldn't find package ubuntuone-jaunty-ppa.deb

I did a search in Synaptic, and the only package that appears there now is python-ubuntuone-client. However, I do have: http://ppa.launchpad.net/ubuntuone/beta/ubuntu jaunty main
and http://ppa.launchpad.net/ubuntuone/beta/ubuntu jaunty main (Source Code)
in my repository list, and they are checked.

alpha1 (wmstrome) said : #11

I just reviewed the messages when I did "sudo apt-get update && sudo apt-get install ubuntuone*" and it listed all the repositories "Hit", and http://ppa.launchpad.net/ubuntuone/beta/ubuntu jaunty main
and http://ppa.launchpad.net/ubuntuone/beta/ubuntu jaunty main (Source Code) were not in the list.nor do they appear in /etc/apt/sources.list, although they do appear in the Synaptic repositories list.

Elliot Murphy (statik) said : #12

Hi! How can we help resolve this issue? Reading through the backlog of messages here, it's unclear what the current state of the system is.

Would you be able to join the #ubuntuone channel on Freenode IRC in order to get some real-time assistance with this problem? We have someone around each day during the week trying to answer user questions and provide support.

Can you help with this problem?

Provide an answer of your own, or ask alpha1 for more information if necessary.

To post a message you must log in.