files not syncing, authorization failed

Asked by Richard Broughton on 2010-08-10

I noticed that my files stopped syncing after things had been working well. The UbuntuOne preferences window says my machines are disconected and does not list my name or email. The device says <LOCAL_MACHINE>
I get this with u1sdtool:

broughtn@Billfish:~$ u1sdtool -s
State: AUTH_FAILED
    connection: With User With Network
    description: auth failed
    is_connected: False
    is_error: True
    is_online: False
    queues: IDLE

Any suggestions?
Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu One Client Edit question
Assignee:
No assignee Edit question
Solved by:
Richard Broughton
Solved:
2010-08-16
Last query:
2010-08-16
Last reply:
2010-08-13
Richard Broughton (rbroughton) said : #1

Sorry if I did not provide enough information.

I'm wondering if I should just uninstall and reinstall the u1 client and then add my two machines again.

How will this affect the files on the cloud? Would it be better to just delete the files there too and start everything fresh?

Thanks,

John O'Brien (jdobrien) said : #2

uninstalling and resinstalling probably isn't the simplest work around.

It sounds like your machines have not been authorized to use ubuntuone yet or they are now behind a proxy server.
Do you know if this is the case?
Also, which Ubuntu release are you working with?

Richard Broughton (rbroughton) said : #3

They had been working.
I noticed that there were two entries for each machine on my account, one from June, one from July. They had the same names but different numbers. I deleted the two earlier ones and that must have blown the whole thing. There are still two machines supposedly linked to my account with the original names I used but the only option I have is to delete them, not add anything.

I should not be behind a proxy server - u1 had been working reasonably well.

I have release 10.04, kernel 2.6.32-24 generic, GNOME 2.30.2.

Duane Hinnen (duanedesign) said : #4

 Can you try the following and let us know the results?

   1. Quit the Ubuntu One client
   2. Open Applications->Accessories->Passwords and Encryption Keys
   3. Click on the arrow next to "Passwords"
   4. Right-click on the Ubuntu One token and select "Delete"
   5. Go to https://one.ubuntu.com/account/machines/
   6. Click on the checkbox next to your computer
   7. Click the "Remove selected computers" button
   8. Open Me Menu -->Ubuntu One or System --> Preferences --> Ubuntu One
   9. a web page should open, prompting you to add your computer to your Ubuntu One account
  10. Add your computer

If you run into the bug where on step 9 you can not find the 'Add This Computer Button' see this page.
https://wiki.ubuntu.com/UbuntuOne/FAQ#How%20do%20I%20add%20my%20computer?

This should get you correctly authorised.
thank you,
duanedesign

Richard Broughton (rbroughton) said : #5

The machines are now connected. Looks like that did the trick. Thanks!