Ubuntu One - Not Connecting or Syncing

Asked by ibob63 on 2010-07-25

I have had an ubuntu one account for 11 months. I stopped using it 8 months ago. However, I have upgraded to 10.04, purchased the 50 gig paid version of ubuntu one and wanted to start using it and move away from Dropbox.

I have done all that but basically isn't syncing and I can't work out why. I have double checked all the settings and installed the client and reinstall it again ( as per here https://answers.edge.launchpad.net/ubuntuone-client/+faq/778 ). However, it just sits there saying 'Disconnected'.

Anyhow ideas how I can get this going? Is there any kind of logging for this software?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu One Client Edit question
Assignee:
No assignee Edit question
Solved by:
ibob63
Solved:
2010-07-26
Last query:
2010-07-26
Last reply:
2010-07-26
Duane Hinnen (duanedesign) said : #1

ibob63,
Under the 'Devices' tab is your computers name showing up or does it say <local machine>?
Also under the 'Services' tab make sure File Sync is checked.
Can you run the following command in a Terminal and post the results:

u1sdtool -s

thank you,
duanedesign

ibob63 (james-tuthill) said : #2
ibob63 (james-tuthill) said : #3

Hi,

Under the devices tab it says my computer name "james-lenovo". Anyhow, since rebooting it is now connecting and says "Synchronisation in progress...". So it look like it is working now. Hurray!

Thank you for your help and I am sorry to have wasted your time. Here is the results of u1sdtool -s

    State: QUEUE_MANAGER
    connection: With User With Network
    description: processing queues
    is_connected: True
    is_error: False
    is_online: True
    queues: WORKING_ON_BOTH

Thanks for your help,

James

p.s. I don't know if the Ubuntu One team read this - but this software looks like it really needs more testing and design work. Why would a reboot fix the issue? Something somewhere is wrong and needs fixing. Are the services not being restarted properly? I run lots of ubuntu machines and linux software and this software seems the odd one out - especially from the Ubuntu team. I can't be the only one to have this problem.

Also, the tools to fix the problem wasn't available. Why isn't this the debug output available on the GUI? I am happy playing with the command line but where was the reference to u1sdtool in the documentation? The only installation instructions are pretty basic : https://one.ubuntu.com/support/installation/

Anyhow, It would be great if the ubuntu one team could be inspired by Dropbox which provides a really good GUI - it is simple but just works and has much more information. Perhaps, the ubuntu one team could spend less time adding features and more time getting the basic software working, it doesn't inspire confidence and I nearly moved my subscription back to Dropbox.