Cannot add computer

Asked by Robert Bell on 2010-05-08

Hello,

Had a bit of a day messing around with my PC trying to upgrade my Ubuntu (long story short, ended up doing a fresh install)

When I open up Ubuntu One, it loads, then immediately (ie i click nothing else) I get :

 " Error: Got empty result for devices list. "

It doesn't open up a new tab in Firefox to take me to the log in page or anything.

In the Ubuntu One preferences window, I have Name: Unknown, Email: Unknown, Current Plan: Free

I fear this might be because during the course of today, I did manage to add my computer to UbuntuOne a couple of times, but then removed them from my account online (as those 'versions' of my computer don't exist any more, now running on this stable fresh install). This doesnt really make sense to me (as this computer is effectively a new one to UbuntuOne right?) but its the only reason I can think of

I have re-installed UbuntuOne to see if it made any difference, to no avail

Cheers for any help, happy to provide more information

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu One Client Edit question
Assignee:
No assignee Edit question
Solved by:
dwp0980
Solved:
2010-05-11
Last query:
2010-05-11
Last reply:
2010-05-11
Best dwp0980 (dwp0980) said : #1

Hi - I had the same symptoms and an answer from Question #109561 solved this for me. . .

sudo apt-get install ubuntuone-client-tools
u1sync --authorize (I followed the prompts to add a new machine in the browser window that appeared - don't know if this is necessary or not).
sudo reboot

Hope this helps you.

Hi,

I had the same problem, but the solution from dwp0980 did the trick. Thanks dwp0980!

thank you, thats solved it :D

Thanks dwp0980, that solved my question.

I had the same issue, and managed to solve it by following the directions posted by dwp0980 (for which I thank you), Perhaps an addition to Ubuntu One is called for to add a button to the Your Machines page to allow this to be automated. This is probably not the right page to make these suggestions but I would be happy to do so if somebody can point me in the right direction.

cluster (philemon) said : #6

The same issue on my machine. But thanks to dwp0980 I'm up and running again ;-). I have no clue what the reason for this behavior is, but it sure could be a "show stopper" for a newbie...

Bruno Munoz (bruno-bmunoz) said : #7

same issue, same resolution with dwp0980 command

Bruno Munoz (bruno-bmunoz) said : #8

forgot to precise that
$ u1sdtool -q; killall ubuntuone-login; u1sdtool -c
do not solve this issue.
it has the 1st time i've launch ubuntuone client and I was also unable to add a 1st computer.
but deleting and adding the same host was only solve by
$ u1sync --authorize

Miguel Rozsas (marozsas) said : #9

hi dwp0980 ! Thanks for discovering this. It worked like a charm for me.

ThomasLee82 (kamiyasha) said : #10

Sadly, when I tried dwq0980's solution, it failed for me. Any recommendations?

$ u1sync --authorize
Traceback (most recent call last):
  File "/usr/bin/u1sync", line 27, in <module>
    from ubuntuone.u1sync.main import main
  File "/usr/lib/pymodules/python2.6/ubuntuone/u1sync/main.py", line 43, in <module>
    from ubuntuone.u1sync.client import (
  File "/usr/lib/pymodules/python2.6/ubuntuone/u1sync/client.py", line 40, in <module>
    from ubuntu_sso.config import get_config as get_oauth_config
ImportError: No module named config

Duane Hinnen (duanedesign) said : #11

the u1sync tool is mainly for testing. Though some users have found a use for it to authorize their computers. You should be prompted to add your computer when opening the Ubuntu One Preferences for the first time. If this does not happen it is usually because you have an Ubuntu One Token left over from another install or a previous Auth attempt. In that case you can do the following. (This varies depending on the version of Ubuntu. These instructions are for Lucid 10.04. In older versions Ubuntu One is found under Applications -> Internet -> Ubuntu One. In Maverick Password and Encryption Keys is found under System -> Preferences -> Password and Encryption Keys.)

   1. Quit the Ubuntu One client
   2. Open Applications->Accessories->Passwords and Encryption Keys
   3. Click on the arrow next to "Passwords"
   4. Right-click on the Ubuntu One token and select "Delete"
   5. Go to https://one.ubuntu.com/account/machines/
   6. Click on the checkbox next to your computer
   7. Click the "Remove selected computers" button
   8. Open Me Menu->Ubuntu One or System -> Preferences -> Ubuntu One
   9. a web page should open, prompting you to add your computer to your Ubuntu One account
  10. Add your computer

thank you,
duanedesign

Snahrck (hansenclever) said : #12

For me this is not working. I tried the procedure described by duanedesign more than twice, and I always get the same error. I have one computer which syncs fine. But this Maveric fresh installed laptop will not sync.