Issue with UbuntuOne and Lucid

Asked by Robert Schilt on 2010-05-05

I continue to experience issues with UbuntuOne on Lucid.

Issues seems to start after removing device from my UbuntuOne subscription. If I re-install Lucid - all works well and UbuntuOne prompts me to add my device but other than a rebuild nothing I have tried successfully adds the device back to UbuntuOne again. I have tried all the suggestions in FAQ (eg: full uninstall/reinstall of UbuntuOne and a few of the UbuntuOne command line tools to force registration).

I have also looked in the logs and have not been able to observe anything untoward. Interestingly a few of the FAQ and tickets suggest removing UbuntuOne from the local Keyring and I have never been able to sight an UbuntuOne password entry in my laptop's keyring. Perhaps an issue with how UbuntuOne interacts with the keyring?

I have Backports and UbuntuOne PPA both enabled and am therefore running the latest updates.

I would really appreciate some help on this one as I am very keen to test out cloud services on offer by Ubuntu.

Robert

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu One Client Edit question
Assignee:
No assignee Edit question
Last query:
2010-05-15
Last reply:
2010-05-19
Duane Hinnen (duanedesign) said : #1

There have been a bug some users are experiencing that prevents them from adding their computer. Can you please try the following.

   1. close the Ubuntu One Preferences application window (if it's already open)
   2. open your Terminal (located in Applications >> Accessories)
   3. and type the following:

 u1sdtool -q; killall ubuntuone-login; u1sdtool -c

This should force a web browser to open and put you at step 2 of this process:
https://one.ubuntu.com/support/installation/

thank you,
duanedesign

Robert Schilt (rschilt) said : #2

Thanks for getting back to me.

Tried your suggestion above and It does not force a browser to open prompting me to add a device. Currently running Firefox 3.6.3 on Lucid.

By the way - I had come across your suggestion in one of the UbuntuOne tickets and it did not work for me then either.

Any further suggestions?

Robert

Joshua Hoover (joshuahoover) said : #3

Hi Robert,

We've been unable to reproduce this issue where certain users never get the "add your computer" step. Can you answer the following questions to help us eliminate some possibilities?

1. Are you behind a proxy server?
2. How do you connect to the network? (Network Manager?)
3. If you run the following command from a terminal, do you get any output? ubuntuone-preferences
4. Can you try running the following in a terminal session? wget -q http://launchpadlibrarian.net/34282008/nm-checker && python nm-checker

It would also be good if you could turn on debug mode for the login process so we can get that debug log in a bug report. Can you try the following?

1. In a terminal session run: u1sdtool -d; u1sdtool -q; gksu gedit /usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/logger.py
2. In gedit, find the line "LOG_LEVEL = logging.INFO" and change to "LOG_LEVEL = logging.DEBUG"
3. Save and close the logger.py file in gedit
4. In a terminal session run: u1sdtool --start; u1sdtool -c

One you do this, please let me know here.

Thank you,

Joshua

Robert Schilt (rschilt) said : #4

Hi Joshua,

Thanks for getting back to me. I have since re-installed a fresh copy of 10.04 and the issue not being able to "add your computer" persists. Adding ppa:ubuntuone/beta and updating Ubuntuone packages accordingly yields exactly the same results.

I am therefore more than happy to assist with this issue by providing additional details/logs as required. Here are the responses to your questions:

1) I am not behind a proxy server.

2) I am connecting via: a) Network Manager and b) Mobile Broadband client. Both connection methods yield same result.

3) When I run ubuntuone-preferences from the command line I am presented with the "Ubuntu One Preferences" screen.

4) When I run "wget -q http://launchpadlibrarian.net/34282008/nm-checker && python nm-checker" I get the following response:
Got state: 4

5) After setting "LOG_LEVEL = logging.DEBUG" I re-ran the ubuntuone login process and have attached oauth-login.log as requested.

Thanks,

Robert

Robert Schilt (rschilt) said : #5

Joshua,

Sorry but I was unable to find a way to attach oauth-login.log and as it's only a short one I have added it here as text. I noticed that there is a missing keyring entry for UbuntuOne.

2010-05-14 07:46:35,922:922.110080719 UbuntuOne.OAuthDesktop.main Creating a LoginProcessor
2010-05-14 07:46:35,922:922.642946243 UbuntuOne.OAuthDesktop.main Hooking libnotify
2010-05-14 07:46:35,922:922.861099243 UbuntuOne.OAuthDesktop.main Getting configuration
2010-05-14 07:46:35,923:923.742055893 UbuntuOne.OAuthDesktop.main Login D-Bus service starting up
2010-05-14 07:46:35,929:929.024934769 ubuntuone-login Starting Ubuntu One login manager version 1.2.1
2010-05-14 07:46:35,945:945.175886154 UbuntuOne.OAuthDesktop.main login() D-Bus message received with realm='https://ubuntuone.com', consumer_key='ubuntuone'
2010-05-14 07:46:35,946:946.819067001 UbuntuOne.OAuthDesktop.main Initiating OAuth login in LoginProcessor
2010-05-14 07:46:35,947:947.043895721 UbuntuOne.OAuthDesktop.main Obtaining OAuth urls
2010-05-14 07:46:35,947:947.241067886 UbuntuOne.OAuthDesktop.main Fetching config URLs for realm='https://ubuntuone.com'
2010-05-14 07:46:35,947:947.555065155 UbuntuOne.OAuthDesktop.main Realm 'https://ubuntuone.com' is not in config
2010-05-14 07:46:35,948:948.01402092 UbuntuOne.OAuthDesktop.main OAuth URLs are: request='https://ubuntuone.com/oauth/request/', userauth='https://ubuntuone.com/oauth/authorize/', access='https://ubuntuone.com/oauth/access/', secret='hammertime'
2010-05-14 07:46:36,158:158.261060715 UbuntuOne.OAuthDesktop.auth auth.AuthorisationClient created with parameters realm='https://ubuntuone.com', request_token_url='https://ubuntuone.com/oauth/request/', user_authorisation_url='https://ubuntuone.com/oauth/authorize/',access_token_url='https://ubuntuone.com/oauth/access/', consumer_key='ubuntuone', callback_parent='<bound method LoginProcessor.got_token of <ubuntuone.oauthdesktop.main.LoginProcessor instance at 0x1d97cb0>>'
2010-05-14 07:46:36,171:171.293020248 UbuntuOne.OAuthDesktop.main Calling auth.client.ensure_access_token in thread
2010-05-14 07:46:37,558:558.530092239 UbuntuOne.OAuthDesktop.auth Trying to fetch the token from the keyring
2010-05-14 07:46:37,566:566.293954849 UbuntuOne.OAuthDesktop.auth Access token was not in the keyring
2010-05-14 07:46:37,566:566.651105881 UbuntuOne.OAuthDesktop.auth Checking whether we are online
2010-05-14 07:46:37,573:573.174953461 UbuntuOne.OAuthDesktop.auth We are not online

Joshua Hoover (joshuahoover) said : #6

Hi Robert,

Thank you for answering all of my questions! Ubuntu One isn't starting up because the software is asking Network Manager if there is a connection. Network Manager is returning a response of "disconnected" so Ubuntu One never opens the web browser prompting you to add your computer to your Ubuntu One account. Can you try running the following commands in a terminal session and let me know how it goes?

dbus-send --print-reply --session --type=method_call --dest=com.ubuntuone.SyncDaemon /events com.ubuntuone.SyncDaemon.Events.push_event string:SYS_NET_CONNECTED array:string:

u1sdtool -q; killall ubuntuone-login; u1sdtool -c

Thank you,

Joshua

Robert Schilt (rschilt) said : #7

Hi Joshua,

Thanks for responding.

I ran the commands you suggested twice. First when connected via 3G on Mobile Broadband (USB) and the other when connected via Wireless (Network Manager).

1) When connected via the 3G card I get the following (with no browser opening up):

robert@robert-toshiba:~$ dbus-send --print-reply --session --type=method_call --dest=com.ubuntuone.SyncDaemon /events com.ubuntuone.SyncDaemon.Events.push_event string:SYS_NET_CONNECTED array:string:
method return sender=:1.94 -> dest=:1.137 reply_serial=2
robert@robert-toshiba:~$ u1sdtool -q; killall ubuntuone-login; u1sdtool -c
ubuntuone-syncdaemon stopped.
ubuntuone-login: no process found
robert@robert-toshiba:~$

2) When connected via Wireless I get the following (interestingly the browser opens up and prompts me to add device!):

robert@robert-toshiba:~$ dbus-send --print-reply --session --type=method_call --dest=com.ubuntuone.SyncDaemon /events com.ubuntuone.SyncDaemon.Events.push_event string:SYS_NET_CONNECTED array:string:
method return sender=:1.140 -> dest=:1.169 reply_serial=2
robert@robert-toshiba:~$ u1sdtool -q; killall ubuntuone-login; u1sdtool -c
ubuntuone-syncdaemon stopped.
robert@robert-toshiba:~$

It would appear that UbuntuOne will work through connections configured outside of NetworkManager.

Although I now have a connection... I now appear to have synchronisation issues between Contacts in Evolution and UbuntuOne.

I happy to continue problem resolution with you.

Robert

Robert Schilt (rschilt) said : #8

Joshua,

FYI... I have now configured the Mobile Broadband connection via NetworkManager and it seems to be working OK.

Note that I'm still having issues with synchronisation.

Robert Schilt (rschilt) said : #9

Sync issues are with Evolution Contacts.
Files seem to be syncing OK.

Robert Schilt (rschilt) said : #10

Hi Joshua,

Re the syncing issue with Contacts...

I noticed that in desktop-couch-replication.log periodically the following error appears:

ServerError: (503, '<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">\n<html><head>\n<title>503 Service Temporarily Unavailable</title>\n</head><body>\n<h1>Service Temporarily Unavailable</h1>\n<p>The server is temporarily unable to service your\nrequest due to maintenance downtime or capacity\nproblems. Please try again later.</p>\n<hr>\n<address>Apache/2.2.8 (Ubuntu) mod_python/3.3.1 Python/2.5.2 mod_ssl/2.2.8 OpenSSL/0.9.8g Server at couchdb.one.ubuntu.com Port 443</address>\n</body></html>\n')

It would appear that CouchDB has an issue connecting to the UbuntuOne server.

Could this be why my Contacts are failing to synchronise?
Are there any known issues with UbuntuOne server that would be causing this error?

Robert

Robert Schilt (rschilt) said : #11

Hi Joshua,

Interestingly I found the following info at https://wiki.ubuntu.com/UbuntuOne/Status#Contacts:

Monday, May 3, 2010 at 14:32 UTC: Sync between your desktops and the cloud is currently disabled.

Is this still an issue?

Joshua Hoover (joshuahoover) said : #12

Hi Robert,

Yes, syncing contacts between a desktop and the server is still down. We hope to have this back up yet this week.

Thank you,

Joshua

Robert Schilt (rschilt) said : #13

Thanks for getting back to me and good luck!

Can you help with this problem?

Provide an answer of your own, or ask Robert Schilt for more information if necessary.

To post a message you must log in.