Zope installation (package failure; cannot start zope)

Asked by a-r-k-i-b-o-t-t on 2008-08-16

I installed the Zope2.10 on a 8.04.1 but it does not run.

Is this a bug?

I get this simple message if i try to start zope:
Zope2.10: no instances found.

It does not start.

There is no configuration in /etc/zope2.10/

Is the installation package broken?

It also created some useless files directly into my home folder.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu zope2.10 Edit question
Assignee:
No assignee Edit question
Last query:
2008-08-16
Last reply:
2009-09-02
Curtis Hovey (sinzui) said : #1

I'm not sure I can help to get everything running because I don't know much about the older versions of Zope, but I can get you started.

You stalled application libraries, but you still need to do the setting up to create an instance to run with a website. I think you need to run mkzopeinstance.py, a script that was installed with zope. You can see some examples of how to do this at http://www.zope.org/Members/logik/HowTo.2004-09-15.5641.

http://www.zope.org/ is the best resource for documentation about setting up Zope.

Paul Flint (flint) said : #2

the control of the zope programs is a bit muddled. mkzopeinstance will create an instance in the directory specified in the script. This subdirectory will also contain a bin directory where the control tools are available to start, stop etc this particular instance.

The /etc/init.d/zope?? script should key off of these but does not appear to.

I would like to declare this a bug.

Can you help with this problem?

Provide an answer of your own, or ask a-r-k-i-b-o-t-t for more information if necessary.

To post a message you must log in.