[solved] in 18.04 using zfs shared via nfs, sub-directories incorrectly received 0777 permissions

Asked by mrdrthom on 2019-02-04

keywords: zfs nfs nfsver sharenfs acltype posixacl 0777

this took me a long time to debug and i'm sharing it on the hopes of sparing someone else such pain

setup: ubuntu 18.04 based linux zfs server sharing via nfs (using the sharenfs property). client was also linux 18.04 based (e.g. linux mint 19.1). client mounts remote nfs share in the standard manner with line in /etc/fstab

bug: when client makes a directory (e.g. "mkdir /mnt/remote/test" ) the permissions of the resulting directory are 0777 regardless of the state of all the normal things which should determine the permissions

smoking gun: two VMs configured as zfs clients via nfs, identical except ubuntu version (server 16.04LTS and 18.04LTS). the problem occurred with the 18.04 client but not with the 16.04 client. running "nfsstat -m" showed nfsvers=4.0 for ubuntu=16.04 and nfsver=4.2 for ubuntu=18.04.

workaround: on the server set the zfs property acltype=posixacl on the zpool or on specific zfs's

out-of-box bad: as best as I can tell this occurs with the out-of-the-box default settings when you use a Ubuntu_18.04-based OS for both zfs server and zfs client.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu zfs-linux Edit question
Assignee:
No assignee Edit question
Last query:
2019-02-05
Last reply:
2019-02-21

Please mark as solved if this is solved..........

mrdrthom (mrdrthom) said : #2

shouldn't the default setting for either the zfs server or the zfs client be looked at? it appears to me that the two default settings are incompatible and yield the above 0777 permissions bug.

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.