zfs-linux, ubuntu 18.04 cannot set zfs mountpoint=legacy

Asked by Peter Goodall on 2018-09-08

I am creating an ext4 volume on an Ubuntu bionic workstation with zfs root. By my reading, according to manuals I should be able to set the mountpoint attribute to legacy, or it shoud have been set to legacy.

I need to create an ext4 volume because Dropbox has withdrawn support for anything except ext4 on Linux.

I don’t believe this is a trivial or useless issue, leaves the type of mountpoint type blank. If I examine the system I am getting a blank field where I should not.

https://docs.oracle.com/cd/E19253-01/819-5461/gbaln/index.html
https://github.com/zfsonlinux/zfs/wiki/Ubuntu-ZFS-mountall-FAQ-and-troubleshooting

zfs create -o compression=lz4 -V 4.5G tank/my-ext4
export myz=/dev/zvol/tank/my-ext4
mkfs.ext4 $myz
mkdir ~/ext4_dir
mount $myz ~/ext4_dir
mount | grep ext4

> /dev/zd32 on /root/ext4_dir type ext4 (rw,relatime,stripe=8,data=ordered)

zfs list tank/my-ext4
> NAME USED AVAIL REFER MOUNTPOINT
> tank/my-ext4 22.8M 2.56T 96K -

zfs set mountpoint=legacy tank/my-ext4
> cannot set property for 'tank/my-ext4': 'mountpoint' does not apply to datasets of this type

aptitude search zfs | grep '^i'
i A libzfs2linux - OpenZFS filesystem library for Linux
i zfs-initramfs - OpenZFS root filesystem capabilities for Linux - initramfs
i A zfs-zed - OpenZFS Event Daemon
i zfsutils-linux - command-line tools to manage OpenZFS filesystems

NB: I couldn't set the package for this question as 'zfsutils-linux' - not found

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu zfs-linux Edit question
Assignee:
No assignee Edit question
Last query:
2018-10-09
Last reply:
2018-10-09
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Peter Goodall (pjgoodall) said : #2

Instead of just expiring issues, why not notify it’s creater a little before the 15 days?

Peter Goodall (pjgoodall) said : #3

I would like to thank you and all the horses you rode in on, for your succinct and helpful responses 👍

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Peter Goodall (pjgoodall) said : #5

Why is it so hard to give a polite answer. There must be a reason.
I apologise for having such trivial concerns with conformance to APIs

Manfred Hampl (m-hampl) said : #6

Sorry that you did not receive any response so far, but it seems that nobody knows an answer (neither do I).

A web search for the error message that you receive brings up the following (quite old) hit:
https://www.unix.com/solaris/96088-how-do-i-export-zfs-filesystem-i-created.html
The -V option apparently is mutually exclusive with the mountpoint option.
(No idea if that is true and still valid, whether it is related to your case, etc.)

Peter Goodall (pjgoodall) said : #7

Thank you Manfred,
Usually I get knowledgeable replies quite quickly to questions on launchpad. Pardon my theatrics 😀. It does seem important to provide clearer metadata than a blank. Perhaps declaring any other file system as ‘legacy’ in the api was theatrics itself.

I’d like to see an alternative descriptive field where an identifier for the hosted filesystem could be given.

Thanks again,
—Peter G

Manfred Hampl (m-hampl) said : #8

It seems to me that you now are requesting a global change of the zfs utilities (not only the version packages for Ubuntu).
In that case you should refer to the upstream source, which probably is https://zfsonlinux.org/

Can you help with this problem?

Provide an answer of your own, or ask Peter Goodall for more information if necessary.

To post a message you must log in.