unable to install

Asked by Boris Rybalkin on 2011-07-07

Hi I am trying to install zeroc-ice33, but it aks for lower version of python.
Could you help?

bob@bob:/my/software/ice/Ice-3.4.2/java$ sudo aptitude install zeroc-ice33
The following NEW packages will be installed:
  apache2-mpm-prefork{a} ice33-services{a} ice33-slice{a} ice33-translators{a} icebox{a} icegrid-gui{a} libapache2-mod-php5{a} libfreeze33{a} libglacier2-33{a} libicebox33{a} libicebox34{a}
  libicegrid33{a} libicepatch2-33{a} libicessl33{a} libicestorm33{a} libiceutil33{a} libiceutil34{a} libicexml33{a} libslice33{a} libslice34{a} libzeroc-ice3.3-cil{a} libzeroc-ice3.3-java{a}
  libzeroc-ice33{a} libzeroc-ice33-dbg{a} libzeroc-ice33-dev{a} libzeroc-ice34{a} php-zeroc-ice{a} php5{a} php5-cli{a} php5-common{a} python-zeroc-ice{ab} zeroc-ice33
0 packages upgraded, 32 newly installed, 0 to remove and 245 not upgraded.
Need to get 64.1 MB of archives. After unpacking 252 MB will be used.
The following packages have unmet dependencies:
  python-zeroc-ice: Depends: python (< 2.7) but 2.7.1-0ubuntu5 is installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1) python-zeroc-ice [Not Installed]
2) zeroc-ice33 [Not Installed]

Question information

English Edit question
Ubuntu zeroc-ice Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:

Can you give the output of:

lsb)_release -a; uname -a



lsb_release -a; uname -a

Boris Rybalkin (ribalkin) said : #3

bob@bob:$ lsb_release -a; uname -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
Linux bob 2.6.38-9-generic #43-Ubuntu SMP Thu Apr 28 15:23:06 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

What is the output of:

python -version


Manfred Hampl (m-hampl) said : #5

the line "... to remove and 245 not upgraded" indicates that something in your package setup is not fully correct, maybe you have inconsistencies in the version of packages that are installed. To find out some more details please open a terminal and issue the following command

apt-cache policy zeroc-ice33 python-zeroc-ice zeroc-ice33 python

and then select all output and paste it into a new message of this question thread.

Boris Rybalkin (ribalkin) said : #6

bob@bob:/$ python -V
Python 2.7.1+

Boris Rybalkin (ribalkin) said : #7

Ran aptitude dist-upgrade to make sure everything is up to date, but id did not help.

Here is the policy output:
bob@bob:/my/projects/uCloud$ apt-cache policy zeroc-ice33 python-zeroc-ice zeroc-ice33 python
  Installed: 2.7.1-0ubuntu5
  Candidate: 2.7.1-0ubuntu5
  Version table:
 *** 2.7.1-0ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
        100 /var/lib/dpkg/status
  Installed: (none)
  Candidate: 3.4.2-1etreus1
  Version table:
     3.4.2-1etreus1 0
        500 http://ppa.launchpad.net/nicotra-andrea/ppa-etreus/ubuntu/ natty/main amd64 Packages
     3.3.1-12build1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe amd64 Packages
  Installed: (none)
  Candidate: 3.3.1-12build1
  Version table:
     3.3.1-12build1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe amd64 Packages

Best Manfred Hampl (m-hampl) said : #8

The problem is with the ppa nicotra-andrea/ppa-etreus:

The version of python-zeroc-ice 3.4.2-1etreus1 has a dependency on python << 2.7
The standard version of python-zeroc-ice 3.3.1-12build1 has a dependency on python << 2.8

Two possibilities:
1. disable the nicotra-andrea/ppa-etreus ppa in your software sources and try the installation again (should provide 3.3.1)


2. ask nicotra-andrea to correct that dependency in the ppa, because currently that package is not installable on a standard natty system (would deliver version 3.4.2)

Boris Rybalkin (ribalkin) said : #9

You are right, removing the nicotra-andrea/ppa-etreus ppa solved the problem.
Thank you very much!

Boris Rybalkin (ribalkin) said : #10

Thanks Manfred Hampl, that solved my question.