separate home folder

Asked by las on 2010-02-03

Im testing 10.04 so i made a copy of my original home and gave it as /home in fstab.Everything works fine but some manually installed apps.Is there a way to install my apps automatically when I move my /home to a separate partition.I tried to use synaptics save marking but in after I read markings in 10.04 it gave me broken packages...It would be nice if all the apps installd can be marked and saved without binding it to a single version of ubuntu.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Last query:
2010-02-04
Last reply:
2010-02-05

Your question is a little mixed up, the title regards home folders then you start talking about automatically installing apps.

Can you clarify your question please

las (bandara-ls) said : #2

Sorry about not being clear.

1)By using a separate home folder I tried to test 10.04.First I copied my current home to a separate partition and gave 10.04 it as my home folder so I can test all apps I'm using currently

2)But most of my apps are not there coz I haven't installed them

3)I have to go through a written down list of apps to install my apps manually

4)I tried to use synaptic's save all markings feature to get my old apps list

5)When i read that markings in 10.04 synaptic's give me broken packages.(coz 9.04 specific lib files etc are there too)

6)Is there a way to automate instillation of only apps i use by way of saving them in 9.10 and reading in 10.04?

Thanks in advance

To replicate your packages selection on another machine (or restore it if re-installing), you can type:

aptitude --display-format '%p' search '?installed!?automatic' > ~/my-packages

move the file "my-packages" to the other machine, and there type:

sudo xargs aptitude --schedule-only install < my-packages ; sudo aptitude install

This will install the same packages on the other system

las (bandara-ls) said : #4

nothing happend and gave me this output...

09:49:44-las@las-desktop:~$ sudo xargs aptitude --schedule-only install < my-packages ; sudo
[sudo] password for las:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Initializing package states... Done
Writing extended state information... Done
Couldn't find package "amrnb". However, the following
packages contain "amrnb" in their name:
  libopencore-amrnb-dev libopencore-amrnb0-dbg libopencore-amrnb0
Couldn't find package "amrwb". However, the following
packages contain "amrwb" in their name:
  libopencore-amrwb0-dbg libopencore-amrwb-dev libopencore-amrwb0
Couldn't find any package whose name or description matched "app-runner"
No candidate version found for empathy-doc
Couldn't find any package whose name or description matched "firefox-3.7-branding"
Couldn't find any package whose name or description matched "gnome-blackjack"
Couldn't find any package whose name or description matched "ip1000-driver"
Couldn't find any package whose name or description matched "libboost-date-time1.38.0"
No candidate version found for libboost-system1.38.0
No candidate version found for libboost-thread1.38.0
No candidate version found for libdvdcss2
Couldn't find any package whose name or description matched "libevdocument1"
Couldn't find any package whose name or description matched "libevview1"
Couldn't find any package whose name or description matched "libgdata5"
Couldn't find any package whose name or description matched "libicu40"
Couldn't find any package whose name or description matched "libkadm5clnt6"
No candidate version found for libmetacity0
No candidate version found for libssh-3
Couldn't find any package whose name or description matched "linux-image-2.6.31-18-generic"
Couldn't find any package whose name or description matched "medibuntu-keyring"
Couldn't find any package whose name or description matched "mobilemediaconverter"
Couldn't find any package whose name or description matched "nvidia-195-modaliases"
Couldn't find any package whose name or description matched "nvidia-glx-195"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-core01"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-core02"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-core03"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-core04"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-core05"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-core06"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-core07"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-en-us"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-images"
Couldn't find any package whose name or description matched "ooodev-ure"
Couldn't find any package whose name or description matched "pdfmod"
Couldn't find any package whose name or description matched "pulseaudio-equalizer"
No candidate version found for python-lazr-restfulclient
No candidate version found for python-lazr-uri
Couldn't find any package whose name or description matched "q7z"
Couldn't find any package whose name or description matched "qink"
Couldn't find any package whose name or description matched "realplay"
No candidate version found for same-gnome
Couldn't find any package whose name or description matched "sun-java6-bin"
No candidate version found for sun-java6-plugin
No candidate version found for ubuntu-gdm-themes
Couldn't find any package whose name or description matched "ubuntuone-ppa-beta"
Couldn't find any package whose name or description matched "umtsmon"
No candidate version found for w32codecs
Couldn't find package "amrnb". However, the following
packages contain "amrnb" in their name:
  libopencore-amrnb-dev libopencore-amrnb0-dbg libopencore-amrnb0
Couldn't find package "amrwb". However, the following
packages contain "amrwb" in their name:
  libopencore-amrwb0-dbg libopencore-amrwb-dev libopencore-amrwb0
Couldn't find any package whose name or description matched "app-runner"
No candidate version found for empathy-doc
Couldn't find any package whose name or description matched "firefox-3.7-branding"
Couldn't find any package whose name or description matched "gnome-blackjack"
Couldn't find any package whose name or description matched "ip1000-driver"
Couldn't find any package whose name or description matched "libboost-date-time1.38.0"
No candidate version found for libboost-system1.38.0
No candidate version found for libboost-thread1.38.0
No candidate version found for libdvdcss2
Couldn't find any package whose name or description matched "libevdocument1"
Couldn't find any package whose name or description matched "libevview1"
Couldn't find any package whose name or description matched "libgdata5"
Couldn't find any package whose name or description matched "libicu40"
Couldn't find any package whose name or description matched "libkadm5clnt6"
No candidate version found for libmetacity0
No candidate version found for libssh-3
Couldn't find any package whose name or description matched "linux-image-2.6.31-18-generic"
Couldn't find any package whose name or description matched "medibuntu-keyring"
Couldn't find any package whose name or description matched "mobilemediaconverter"
Couldn't find any package whose name or description matched "nvidia-195-modaliases"
Couldn't find any package whose name or description matched "nvidia-glx-195"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-core01"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-core02"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-core03"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-core04"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-core05"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-core06"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-core07"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-en-us"
Couldn't find any package whose name or description matched "ooobasis-dev3.2-images"
Couldn't find any package whose name or description matched "ooodev-ure"
Couldn't find any package whose name or description matched "pdfmod"
Couldn't find any package whose name or description matched "pulseaudio-equalizer"
No candidate version found for python-lazr-restfulclient
No candidate version found for python-lazr-uri
Couldn't find any package whose name or description matched "q7z"
Couldn't find any package whose name or description matched "qink"
Couldn't find any package whose name or description matched "realplay"
No candidate version found for same-gnome
Couldn't find any package whose name or description matched "sun-java6-bin"
No candidate version found for sun-java6-plugin
No candidate version found for ubuntu-gdm-themes
Couldn't find any package whose name or description matched "ubuntuone-ppa-beta"
Couldn't find any package whose name or description matched "umtsmon"
No candidate version found for w32codecs
Writing extended state information... Done
usage: sudo [-n] -h | -K | -k | -L | -V | -v
usage: sudo -l[l] [-AnS] [-g groupname|#gid] [-U username] [-u username|#uid]
            [-g groupname|#gid] [command]
usage: sudo [-AbEHnPS] [-C fd] [-g groupname|#gid] [-p prompt] [-u
            username|#uid] [-g groupname|#gid] [VAR=value] [-i|-s] [<command>]
usage: sudo -e [-AnS] [-C fd] [-g groupname|#gid] [-p prompt] [-u
            username|#uid] file ...
09:51:09-las@las-desktop:~$

Ajesh.Avaronnan (avajesh) said : #5

enable the universe and multiverse respositoi\ries in the second pc and run the command
sudo apt-get update. then repeat the abobe step.

Can you help with this problem?

Provide an answer of your own, or ask las for more information if necessary.

To post a message you must log in.