install 9.10 to new hard drive

Asked by M. Parchem on 2010-01-11

Hello,
I recently obtained a ThinkPad T-43 that was retired from my employer. I purchased and installed a new 80G hard drive. We downloaded and burned 9.10 to a CD. After the CD loads and I click to install Ubuntu. On screen 3, the 'Partitioner' window pops-up ; the status bar seems to hang at 47% for some time, then the screen go to page 4. here I get stalled - at screen 4, none of the action buttons across the bottom of the page are active (new,add, change,delete)- they are all grayed out. When I click to go to the next screen an error message pops up saying "no root file system is defined - Please correct this from the partitioning menu". I have read through some of the Q & A here and I did run the CD check and in the Bios the new hard drive is detected. The hard drive is straight out of the box so I have not partitioned it, but there is no other OS on it either.
Any help would be greatly appreciated.

Mitch

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Solved by:
peter b
Solved:
2010-01-15
Last query:
2010-01-15
Last reply:
2010-01-12

Please tell your pc meets the Ubuntu hardware requirements:

https://help.ubuntu.com/community/Installation/SystemRequirements

Then how many hard disk have installed on that pc...

I suggest you (by entering into bios settings) to set the 80 giga hard disk set as primary boot disk... and at required step tell Ubuntu to use entire disk

Thank you

M. Parchem (mparchem) said : #2

Yes meets all requirements : 1.7Ghz processor, 256 ROM, 80G hard drive, CD / DVD RW .... only one hard drive on machine. I re-set Bios to boot from the hard drive first then the CD (remember 9.10 is on the CD). On start-up, it goes right into installing. On page 3 the status bar in the 'Partitioner' now goes to 100% but I still get the same error message on page 4. "No root file system is defined"

Have you verified the md5sum of the downloaded iso before to burn the cd...?
Have you burn the image at lower speed you can d with the data verify active...?
Have you verified your RAM memory using the Ubuntu live install cd menu...?

Thank you

Please increase your RAM memory yuo are under the "Recommended minimum requirements"

Be sure your pc meet Ubuntu requirements https://help.ubuntu.com/community/Installation/SystemRequirements

Please check the md5sum https://help.ubuntu.com/community/HowToMD5SUM of the already downloaded and burned iso
compare with the MD5SUMS you will find here: http://releases.ubuntu.com/karmic/ and if it is wrong

- Install a torrent client: http://www.utorrent.com
- download the iso using a .torrent file from here http://releases.ubuntu.com/karmic/
- recheck the md5sum to be sure is a good iso file

Then burn it, be sure to burn the cd at lower speed you can do and with the data verify active:
https://help.ubuntu.com/community/BurningIsoHowto

Then consider also to download and use the ubuntu-9.10-alternate-i386.iso
so download and burn ubuntu-9.10-alternate-i386.iso.torrent

Hth

M. Parchem (mparchem) said : #5

sorry....my typo - RAM is 256 With the machine in boot from CD mode, I have run the memory test and checked the disc for errors - both passed. In reading the documentation, It says that checking the disc is the same as comparing the MD5SUMS.

peter b (b1pete) said : #6

it appears that your new hd is not initialized.

pls boot ubuntu off CD and follow instructions on

https://help.ubuntu.com/community/InstallingANewHardDrive

in your case the hard drive is drive 0 or in linux parlance /dev/sda (the logical name)

in a terminal pls run

sudo lshw -C disk

make note to be on the safe side of the logical name then proceed with its partitioning as mentioned - either using gparted or parted commands.

M. Parchem (mparchem) said : #7

ok. this seems simple enough but ...I am not familiar with the term open a terminal

To open a terminal go to menu Applications→ Accessories →Terminal

Hth

M. Parchem (mparchem) said : #10

Ok, found and opened terminal ; ran " sudo lshw -c disk" it comes back with data on the CD / DVD. I assuming that it is not detecting the hard drive. Do I need to re-install the hard drive ?

* - cdrom
    description : DVD reader
      (etc.)

Please be sure your hard-disk is detect by entering into your pc bios settings...

Hth

Best peter b (b1pete) said : #12

pls notice spelling - v v important - see below

sudo lshw -C disk

is NOT the same with what you told us

sudo lshw -c disk

notice c it must be C

M. Parchem (mparchem) said : #13

System working now. Thank you all for your help and patience.

M. Parchem (mparchem) said : #14

Thanks peter b, that solved my question.