kernel not getting upgraded after an update

Asked by drskartik on 2010-01-08

I am using ubuntu karmic 9.10.
I recently did a update through update manager and found that the current image is 2.6.31-17. Update process went off smoothly and I was told to restart the comp.
This is the output of uname -a:
Linux kartik-laptop 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux.
Why is my kernel not getting upgraded?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Solved by:
peter b
Solved:
2010-01-09
Last query:
2010-01-09
Last reply:
2010-01-09
peter b (b1pete) said : #1

 a kernel update process should invoke update-grub command automatically.

try doing that after the update completed; in terminal pls do

sudo update-grub

that will generate a new grub.cfg file.

Then also check and upgrade your system using terminal using command line,
open a Terminal from the menu Applications->Accessories->Terminal

Tip: right click with mouse on the terminal title caption and select the item "Always on Top" doing this you will force the terminal window to stay on top of the other windows and you will find very easy to copy single row from this web page into the terminal...
Something more about using the terminal https://help.ubuntu.com/community/UsingTheTerminal

Then type or better copy and paste a row a time then press enter:
(Tip: select the single row to copy then right click into the terminal and to quick paste click with middle button of mouse )

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get --fix-missing install
sudo apt-get clean
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get clean
sudo apt-get autoremove

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

If all fails, can you see the kernel in /boot/ ?
If not, is /boot/ on a seperate partition which is out of space?

drskartik (drskartik) said : #4

I tried the above steps: this is the output from sudo update-grub
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.31-17-generic
Found kernel: /boot/vmlinuz-2.6.31-16-generic
Found kernel: /boot/vmlinuz-2.6.31-15-generic
Found kernel: /boot/vmlinuz-2.6.31-14-generic
Found kernel: /boot/vmlinuz-2.6.31-11-generic
Found GRUB 2: /boot/grub/core.img
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done
 Then i tried the steps as suggested by Marco. ( thanks for the great little tip regarding use of terminal, i used to keep the terminal open in another window and alternate between the browser and terminal using ctrl/alt and arrow to copy and paste my commands!!).
There was 0 packages upgrade/installed or removed.
I rebooted, my uname -a output remains the same.
Is there a problem with menu.lst file, it was made automatically during one kernel update, probably not required in 9.10.
thanks and regards
Kartik

Best peter b (b1pete) said : #5

it appears that you've upgraded from 904 and inherited grub legacy according to the output above (menu,lst still present)

take a look at

https://help.ubuntu.com/community/Grub2

karmic 910 uses grub2 exclusively on new installs. I would recommend to consider and upgrade to grub2 (described v well on the above url); your choice.

After also consider to remove old kernels...

Hth

drskartik (drskartik) said : #7

Thanks Peter and all,
I upgraded to grub2..
now the output from uname -a is Linux kartik-laptop 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 16:20:31 UTC 2009 i686 GNU/Linux.
I had actually done a fresh install from 9.10, somehow the grub version changed. I had both menu.lst and grub.cfg in the /boot/grub folder. The grub version used was 0.97.
Anyhow the problem is solved now.

drskartik (drskartik) said : #8

Thanks peter b, that solved my question.