i can not see my 4GB RAM DDRII 667 on mother board Intel GA-945PL-S3P and Int Core 2 Duo E4500 2.2GHz. Is it something bed? I think what I try and do everything for it ... Thx

Asked by orbites on 2009-08-19

Binary package hint: gnome-system-monitor

my trouble is, what I cannot see 4 GB of RAM in Ubuntu and BIOS too ... PC configuration is 64b .. Gigabyte GA-945PL-S3P , processor Int C2D E4500, 2x 2GB 667MHz Dual DDRII ... nVidia GForce 8600 GT 256MB ... is it possible what mother board can make some partition of RAM invisible and use this for her system requirements? I was use memory test and I had 2 ways at choise. 1st BIOS std RAM (3328MB) and 2nd All RAM (4GB) ... when a choise 2nd, after 1 sec. system halt with errors from 000f0000000 - 3840MB to 000ffffffff ...

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/gnome-system-monitor
NonfreeKernelModules: nvidia
Package: gnome-system-monitor 2.26.0.1-0ubuntu1
ProcEnviron:
 LANG=cs_CZ.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-system-monitor
Uname: Linux 2.6.28-15-generic x86_64

orbites (orbites76) said : #1
Pedro Villavicencio (pedro) said : #2

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

Tom (tom6) said : #3

Hi :)

Don't panic! Linux seldom needs even 2Gb of ram. The standard 32bit Desktop Edition can only see the first 3.5Gb of ram. Also i'm not clear about your hardware but if it's a laptop then some of that will have been taken by the graphics card. Anyway first lets use the command-line
https://help.ubuntu.com/community/UsingTheTerminal
type in

free -m

and copy&paste the results of that into here.
Good luck and regards from
Tom :)

Matthew Tompsett (matthewbpt) said : #4

A 32bit OS can't use a full 4gb of ram, this is a limitation in all 32bit x86 OS's. If you want to use the full 4gb of ram you should install the 64bit edition of Ubuntu.

Jesse (jessehornbuckle) said : #5

Sounds like, or rather is, a BIOS issue. I would go to the setup menu and try to get the ram recognized there before I would point at any issues with the OS. Also like Matt above said all 32 bit OS has a physical limitation of approximately 3 gig of ram (Yes 32 bit Vista can see more than 3 gig but its smoke and mirrors it can't use it) , however regardless of the OS the Moe-Bo (Mother Board) should see all the ram.

Tom (tom6) said : #6

Hi

32bit linux can use over 3.5Gb of ram but only after messing around with kernel modules. I can't remember the name of the module you would need to add in and wouldn't know how to do so anyway. If you bios is showing over 2Gb of ram i really wouldn't worry about trying to get the extra bit into use. Linux tends to be extremely efficient with ram so over 2Gb is an unnecessary luxury anyway. The extra ram is very useful for when you dual-boot into Windows but mainly i would be happy with the longeivity of your current ram. With one stick being hardly used at all it's going to last a very long time ;)))

The 64bit version of Ubuntu doesn't seem to be quite as good as the 32bit version. I have a 64bit machine running 32bit Ubuntu very nicely. I still get to watch full HD movies even though my graphics card's drivers let the machine down a bit.

Please let us know the results of

free -m

as that will show how much ram UBuntu is seeing. If it's only seeing 3.5Gb then that's fine and normal but if it's showing a lot less then we need to seriously look at what's going on. At the moment it's unclear how serious this question is.

Thanks, good luck and regards from
Tom :)

Fabián Rodríguez (magicfab) said : #7

Fabián Rodríguez suggests this article as an answer to your question:
FAQ #669: “I have 4GB or more of RAM but can't see it in Ubuntu. How can I enable support for all my RAM ?”.

Can you help with this problem?

Provide an answer of your own, or ask orbites for more information if necessary.

To post a message you must log in.