movie player not working

Asked by Randy on 2009-03-23

I am using Totem Movie Player which came with Ubuntu 8.10. The problem I am having is when I put a DVD in and try to play it I get an error message "could not read from source".
any ideas on what is wrong?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Solved by:
Craig Huffstetler
Solved:
Last query:
Last reply:
Best Craig Huffstetler (xq) said : #1

On the command line / terminal (Applications > Accessories > Terminal)
issue the following commands to ensure you have the proper support for
what you are trying to do.

Ensure libdvdread3 and libdvdcss2 are installed with the proper plugins to support what you are trying to do by issuing the following command in a Terminal:
sudo apt-get install libdvdcss2 libdvdread3 gstreamer0.10-plugins-ugly

Then execute the command:
sudo /usr/share/doc/libdvdread3/install-css.sh
*This may require a restart.

Do you have ubuntu-restricted-extras installed? If not, you may also want to install it.
sudo apt-get install ubuntu-restricted-extras

You can also use Synaptic to install these packages via the graphic
interface, however the command-line will be easier. It will also be
needed to execute the second command above.

I would also like you to see this page:
https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs
The DVD may be encrypted, which many DVDs are now-a-days...and may require these extra libraries. I'm just trying to cover all of your bases.

Regards,

Craig

Abi ^-^ (abiyasa-eka) said : #2

Hello, try to play it with smplayer, it's great!

Open synaptic package manager, search key smplayer ....

https://help.ubuntu.com/community/MPlayer

Or you can use vlc media player

While Totem-gstreamer can play a DVD automatically when it is inserted into the DVD drive, it cannot navigate the DVD reliably (see Bug #41335). If you use vlc media player you can navigate through the menu, forward in the movie and select subtitles.

https://help.ubuntu.com/community/MultimediaApplications#vlc

Good luck!

Randy (rdumas) said : #3

Thanks Craig Huffstetler, that solved my question.