Desktop effects gives the error "the composite extension does not exist"

Asked by harvester on 2007-05-01

Feisty Fawn,

When I attempt to enable the "Desktop Effects" on my fresh out of the box edition of Feisty Fawn I get an error stating "The Composite extension is not available". Is there something that you can do to help? The upgrade from Edgy Eft went very smoothly. IAs far as I know, I am running gnome. Please help me get all of the wonderful eye candy that you worked so hard to implement on your new release.

In order to attempt to run desktop effects I use the following path: System > Preferences > Desktop Effects

I then receive the error: "The Composite extension is not available"

Thank you for being there and thank you for being so damn cute,

Harvester

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Last query:
2007-05-01
Last reply:
2007-08-22
qxov (qxov) said : #1

Please send /etc/X11/xorg.comf and output from glxinfo command to <email address hidden>

Kataton (cmasvanbring) said : #2

I have the same problem.

Bounatirou (bounatirou) said : #3

I have the same problem.

VirgilNilson (virgiliscocky) said : #4

I also have the same problem.

SuGaR847 (c-zachariades) said : #5

I have the same problem.
For me to able to run Ubuntu I had to install the proprietary drivers for my GFX card ATI Mobility Radeon X1400
To be able to do that I had to modify the /etc/X11/xorg.comf by adding a few lines at the end.
These are the extra lines:

Section "Extensions"
 Option "Composite" "Disable"
EndSection

Section "ServerFlags"
 Option "AIGLX" "off"
EndSection

Sbn (esbenvinsnes) said : #6

Hello cute people.
Got the same problem, didn't understand the answer. (Trying to learn this Terminal language stuff).
Could someone elaborate?
Thank you. I love this.
Sbn

Jim Hutchinson (jphutch) said : #7

Are you asking about editing the xorg.conf file as SuGaR847 suggested?

If so, open a terminal and type (or copy paste)

sudo gedit /etc/X11/xorg.conf

Scroll down to the sections he mentions and make the changes. However, those changes are for an ATI card. If you use nvidia or intel it will be different. Also, you won't have any luck just editing the file. You will also have to install the proprietary driver (with nvidia - I'm not 100% sure about the others). This is supposed to be more or less automatic now. Go to system -> admin -> restricted drivers manager and tick the appropriate box.

Sbn (esbenvinsnes) said : #8

Thanx, I'll try that.

Sbn (esbenvinsnes) said : #9

Now I've typed in the command above in the terminal, and the exentions sections already had those lines, while the serverflags section did not exist. So I did nothing, closed the terminal and went for system - admin - restricted drivers and the appropriate box was already ticked; my nVidia card is installed and working. ???

Jim Hutchinson (jphutch) said : #10

Open a terminal and type

glxgears

It will open a little window with some spinning gears. Watch the terminal. Every 5 seconds it will print a line showing the frame rate. If the driver is working you should have pretty high numbers (this is not a great tool for benchmarking but it's okay to get an idea). I get 5000-6000 on my 7600 GS card. If you are not getting above 2-3000 (depending on your card) the driver is not working.

You can also open up the xorg.conf file and see if your device and screen sections look similar to mine (for nvidia card):

Section "Device"
 Identifier "nVidia Corporation G70 [GeForce 7600 GS]"
 Driver "nvidia"
 Busid "PCI:3:0:0"
 Option "AddARGBVisuals" "True"
 Option "AddARGBGLXVisuals" "True"
 Option "NoLogo" "False"

Section "Screen"
 Identifier "Default Screen"
 Device "nVidia Corporation G70 [GeForce 7600 GS]"
 Monitor "DELL 1907FP"
 Defaultdepth 24
 SubSection "Display"

Notice I have NoLogo set to false. That will give you a splash screen at boot and is good confirmation that things are working.

Hope that helps.

Jim Hutchinson (jphutch) said : #11

BTW, don't change the busid or anything else except options or you could break X. Keep a backup copy handy just in case.

Sbn (esbenvinsnes) said : #12

Hi Jim, I did the glxgears and it showed 5700 or so. How do I open the xorg.conf file?

Sbn (esbenvinsnes) said : #13

Sorry, I found out, this is what showed up:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Nov 9 17:55:20 PST 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen" 0 0
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    InputDevice "stylus" "SendCoreEvents"
    InputDevice "cursor" "SendCoreEvents"
    InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

 # path to defoma fonts
    FontPath "/usr/share/fonts/X11/misc"
    FontPath "/usr/share/fonts/X11/cyrillic"
    FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/Type1"
    FontPath "/usr/share/fonts/X11/100dpi"
    FontPath "/usr/share/fonts/X11/75dpi"
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "vbe"
EndSection

Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "no"
EndSection

Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier "stylus"
    Driver "wacom"
    Option "Device" "/dev/input/wacom"
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier "eraser"
    Driver "wacom"
    Option "Device" "/dev/input/wacom"
    Option "Type" "eraser"
    Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier "cursor"
    Driver "wacom"
    Option "Device" "/dev/input/wacom"
    Option "Type" "cursor"
    Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier "Generic Monitor"
    HorizSync 28.0 - 51.0
    VertRefresh 43.0 - 60.0
    Option "DPMS"
EndSection

Section "Device"
    Identifier "nVidia Corporation G70 [GeForce Go 7600]"
    Driver "nvidia"
EndSection

Section "Screen"
    Identifier "Default Screen"
    Device "nVidia Corporation G70 [GeForce Go 7600]"
    Monitor "Generic Monitor"
    DefaultDepth 24
    Option "AddARGBVisuals" "True"
    Option "AddARGBGLXVisuals" "True"
    Option "NoLogo" "True"
    SubSection "Display"
        Depth 1
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 4
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 8
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 15
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 16
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 24
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
    Option "Composite" "Disable"
EndSection

Jim Hutchinson (jphutch) said : #14

Is this a laptop? I think the go cards are in laptops, right? If so, I think5700 is good (as good or better than my desktop) so I think everything is working fine. Change this line

Option "NoLogo" "True"

to say

Option "NoLogo" "False"

and you should see the nvidia splash when you boot.

Let me know if it's working for you and if there is anything else you need.

Sbn (esbenvinsnes) said : #15

yes i did change the line according to your instructions, but when i try to open desktop effects. i still get this message:The Composite extension is not available
btw i did see the nvidia splash at boot...

Jim Hutchinson (jphutch) said : #16

Well, it sounds like your driver is working so it's no longer a driver question. Desktop effects requires you to install the correct packages. If you open the desktop effects option it will offer to install them. However, it installs compiz packages and I have not had a lot of luck with them. They work but not real well. I suggest following a how to on installing beryl. It seems to work better IMHO. Others may disagree.

You might check this how to

http://wiki.beryl-project.org/wiki/Install_Beryl_on_Ubuntu_Feisty_with_XGL

It should give you good steps to get it working.

Just wondering. How much have you changed things. It's possible that with enough playing around things are less than ideal. Now that you know how to get the driver working it might be worth considering a fresh install. I do it quite often so it's nothing to me. If you are not that comfortable doing installs that's okay. It's just a thought. My approach was mess around until I broke things and then start again. Eventually I quite breaking things so now I don't reinstall so much.

Sbn (esbenvinsnes) said : #17

Hey Jim! I solved everything by reinstalling and running the above operations in the right sequence. Now it's all smooth. Love this OS!
Thank you for being supportive.
Sbn

Jim Hutchinson (jphutch) said : #18

Glad I could help.

HolgerS (hs-linux) said : #19

As I am actually experiencing the same error message when I attempt to enable the "Desktop Effects":

"The Composite extension is not available"

I asked myself after reading all the above text: "What the hell was the solution?"

Could someone make that clear and point out what to do exactly to be enabled to enable it? ;)

Kal-El (clark-jebau) said : #20

hey i have the same problem too. After I type cat/X11/xorg.conf on the terminal it replies "No such file or directory" Please help I cant use other 3D applications I have. Thanks so much people!

Can you help with this problem?

Provide an answer of your own, or ask harvester for more information if necessary.

To post a message you must log in.