can't use SUDO

Asked by ClaudeC on 2007-02-11

 I installed SAMBA and Smb4K and configured it to use super user privileges to mount and unmount shares. This modified a file and now I can't run SUDO. I get the error message "Parse error in /etc/sudoers near line 0". I can not use VISUDO to modify the file I do not have permission. Also after all this the shared files from another computer would not mount. It came up on the screen but went away just as fast. What do I do to get SUDO back and once I do how can I fix Smb4k to mount files from other computers which are Windoze based? I am a newbie to this type of OS HELP please. Thanks in advance for anything you can do for me. Remember keep it simple for I am stupid.

Question information

English Edit question
Ubuntu yelp Edit question
No assignee Edit question
Solved by:
Kees Cook
Last query:
Last reply:
Best Kees Cook (kees) said : #1

Prior to version 0.8.0, smb4k has bug that can destroy the /etc/sudoers file. :(

You will need to reboot, and hit "ESC" at the GRUB menu. Select your "recovery mode" boot option. When your computer is finished booting, you will have a super-user prompt, and you can edit the /etc/sudoers file directly.

The normal contents of the sudoers file should read like this:

Defaults !lecture,tty_tickets,!fqdn
# User privilege specification
root ALL=(ALL) ALL
# Members of the admin group may gain root privileges
%admin ALL=(ALL) ALL

ClaudeC (cgchiaia) said : #2

User confirmed that the request is solved.

jose (jmelerocantos) said : #3

How i can edit the /etc/sudoers when i am in "recovery mode"