Is there limit on USB Hard Disk Drives?

Asked by Shunsuke Akagi on 2013-08-02

I have 6 Internal Hard Disk Drives and I attached 2 USB HDD. Then When I attach the 3rd USB HDD, it is not detected.
The program "Disks" recognize it is there but no option for mount. It has "create partition", etc.
Is this a spec or a bug?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Solved by:
Shunsuke Akagi
Solved:
2013-08-02
Last query:
2013-08-02
Last reply:
2013-08-02

Does fdisk see the drive?

sudo fdisk -l

The defacto limit for USB devices (per controller) is 127, so you are far far from the limit.

When you unplug your drives, do you use the safely remove feature in your OS?

What is the output of:

lsb_release -a; uname -a

Are the drives plugging in to a USB hub, or are they connecting direct to the PC? Is he hub powered? Are the USB drives USB powered or do they have their own power?

Thanks

Shunsuke Akagi (shoon) said : #3

It sounds like there is no limit. And furthermore it is working now.
I tried several combination and several ways then it did not work before. But it is working fine now.
I guess it was just mysterious ubuntu occasion I sometimes encounter.
Thanks for your helps!