Help no longer includes man pages

Asked by Mannex on 2011-05-04

Just installed 11.04. Help in the gui seems to no longer include man page entries by default. I set All Documents on (in the Go menu), then searched for mplayer, and got this lovely entry:

 Unknown Error
 The URI ‘xref:search=mplayer’ could not be parsed.

Very ugly. Even a "No documents found" would have been better than that.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Last query:
2011-05-28
Last reply:
2011-05-05

This is bug 726439. The problem here is not that Yelp didn't find the manpage for mplayer. In that case, even in Ubuntu 11.04, it would have said:

Search results for “mplayer”
No matching help pages found in “Ubuntu Desktop Guide”.

Instead, the problem is that, for some reason, in Ubuntu 11.04, at least on some installations, at least after going to Go > All Documents, all searches (for anything, not just mplayer) fail with that error message. It's not telling you that it searched and found nothing (you're right, that would be a terribly ugly way of saying that). It's telling you that it was unable to search at all. The error message suggests that it interpreted the search action incorrectly and didn't even *know* it was supposed to search for anything.

I highly recommend that you visit the page for bug 726439, mark it as affecting you (you can do this with the green "This bug affects..." link near the top of the page), and post a comment in the bug report saying it affects you and giving the details of your system: Ubuntu release (for you this is Natty), architecture (the command "uname -m" in the Terminal tells you this--on a PC or Intel Mac, if it says x86_64, your architecture is amd64, otherwise it's i386), and yelp package version (you can find this in the Ubuntu Software Center, the Synaptic Package Manager, or by running "apt-cache policy yelp" in the Terminal). In this same comment, you should also answer the question I asked Dylan McCall in comment #3 (whether or not he answers it for his system by the time you post): Do you get this error whenever you search for anything, or just when you attempt searching after clicking Go > All Documents?

It would probably also be a good idea to subscribe to the bug (using the green Subscribe link on the right side of the bug page) to ensure you receive email notifications whenever the bug's status changes or someone posts a comment.

In case you were to miss it, I suppose I should also mention here that in comment #2, Dylan McCall provides a workaround that you can use to view manpages in Yelp even while you are affected by this bug. If you have any trouble implementing that workaround or doing any of the things that I've suggested above, or otherwise need more help with or information about this problem, please feel free to post a reply in this question thread.

Mannex (russ-mannex) said : #2

Thanks for the reply. I thought (erroneously) that it was related to not finding the content since, when I searched previously (before selecting all documents) it was unable to locate anything for mplayer (and yes, man mplayer works:).

I will post to that bug now. Thanks.

I think that in Natty, you have to do Go > All Documents to search for man pages. (But then of course, searches don't work, due to bug 726439.) It's possibly that, due to some separate bug, manual pages cannot be searched for, but I don't see anything to indicate that, at this point.

Shaun McCance (shaunm-gnome) said : #4

Man pages are still there. They're just not browseable in Yelp 3.0.

Search in Yelp 3.0 is per-document. The "All Documents" list is basically a document of its own, which doesn't implement search at the moment. The error message sucks big time. Searching from "All Documents" ought to try to do something, or failing that, at least give a reasonable error.

Even if there were a global search from "All Documents", it's not going to include man or info. Tip for advanced users: Press Ctrl+L, type man:mplayer, press Enter.

Mannex (russ-mannex) said : #5

man:mplayer doesn't work for me. Still no results. Any idea why?

Shaun McCance (shaunm-gnome) said : #6

Not without more information. Do you get an error? What does it say?

Mannex (russ-mannex) said : #7

Oops. Sorry. My fault. Here's the error I get:

Unknown Error
The URI ‘xref:search=man%3Amencoder’ could not be parsed.

Shaun McCance (shaunm-gnome) said : #8

That sounds like you typed man:mplayer into the search field. Press Ctrl+L for the location entry. It's a hidden feature to pass a URI, mainly for people like me who work on docs. But if you're reading a lot of man pages, it's probably useful to you.

Mannex (russ-mannex) said : #9

OK, I figured it out. I thought I had tried it both ways, but I have to back up over the "ghelp:" entry. Thanks! This is a good work-around until yelp gets fixed!

Can you help with this problem?

Provide an answer of your own, or ask Mannex for more information if necessary.

To post a message you must log in.