installing tar.gz files

Asked by Theodore R. Sloper on 2010-09-02

I downloaded a couple of files with the tar.gz designation. How do I install them ?

Thank you

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Last query:
2010-09-02
Last reply:
2010-09-03
François Tissandier (baloo) said : #1

What do you mean by "install"? You mean to install a software ?

If you downloaded a software with this file format, it probably means that it's the source code, so you have to compile it to create the real software (it's a bit like getting the plan & parts of an object, then you have to build it).

If you are not familiar with compiling (like most of us), I would advise you NOT to do it, unless it's REALLY necessary. Most of the time, the softwares are available in the software center, and if they are not, it's often possible to add complementary lists of repositories. The idea in Ubuntu (and in most Linux systems) is to get the softwares through the tools, NOT from websites. It's quite different from Windows.

Theodore R. Sloper (tsloper1) said : #2

Yes I am trying to install a video program and do not understand how to do it. I got the file from sourceforge.

François Tissandier (baloo) said : #3

May I know the name of the software please ?

Theodore R. Sloper (tsloper1) said : #4

It's nvrec-20041227.tar.gz and cvs-latest-driver-zoran.tar.gz

Also I downloaded mjpegtools-1.9 from ubuntu but it does not show up in my directory

Theodore R. Sloper (tsloper1) said : #6

It seems that there is no way to install .tar.gz files. I've tried reading, but everything is for the older linux on tarballs.

François Tissandier (baloo) said : #7

NVrec is not updated since 2004 :) It could be very complicated to make it work with a recent system.

If you are not familiar with compiling, I would really really advise you to use what is in the Software Center. Then you can add more repositories if necessary, then you can look online for ".deb" files, they are the installers for Ubuntu.

What do you want to do with this software?

Theodore R. Sloper (tsloper1) said : #8

I have a DC10+ video capture card and am looking to install it. I have looked all over the internet and Ubuntu and all that I can find is tarballs. This has become very fruitless for me.
I am very frustrated. I can't even find the mjpegtools file that I downloaded.

Thank you very much for your help

François Tissandier (baloo) said : #9

I'm not sure if you really need a driver...
It's a PCI card right?
Can you copy paste the output of "lspci" here please ? (enter the command in a terminal)

Theodore R. Sloper (tsloper1) said : #10

ted@ted-desktop:~$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 760/M760 Host (rev 03)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] (rev 36)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] RAID bus controller 180 SATA/PATA [SiS] (rev 01)
00:07.0 Multimedia video controller: Zoran Corporation ZR36057PQC Video cutting chipset (rev 02)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
ted@ted-desktop:~$

The only thing I see is ZR36057PQC. I do not have anything that is recognizing the card.

François Tissandier (baloo) said : #11

From what I see, the card is recognized, you don't need a driver I think.
You need to find a tool to capture the video, and after a quick look on online ressource, it doesn't look that great.

Mjpegtools should work, but there is no interface. As the name is saying, it's just tools. I think there is one called "lavrec" to record from the card. But you must use it in the terminal, it's not user friendly. You can maybe try "dvr", it's in the software center.

Theodore R. Sloper (tsloper1) said : #12

That's it!! I QUIT !!!!!!!!!
Thank you very much for your much appreciated help Francois, but this is mission impossible. I installed the DVR and cannot see it in my start up menu. I had installed kdenlive but it only gave me three choices of which I could not use, They were Firewire, Video4linux and screengrab. Other programs that I installed also disappeared into space too. You used to be able to install tar.gz files a long time ago.

Once again,

Thank you

Francois

François Tissandier (baloo) said : #13

Yes, it's clearly not what Linux is good at.
Just for your information, when you install a package like MJPEGtools, it's not displayed in the menus, as there is no graphical interface for it. It's a bit like an "expert" tool. You can run it from the terminal. (type lavrec from the terminal for instance, it will run it, but you need to enter the right settings in the command). For DVR, I don't know, could be the same, or require a reboot. Anyway, video capture is much easier in Windows, I never captured anything in my Ubuntu, my Windows XP is my primary OS for video work ;)

Theodore R. Sloper (tsloper1) said : #14

I agree about Windows XP. That's what I had. I was using pinnacle to capture.

I found Arista Transcoder. It sees my DC10+ card but when I run it the program stops and says "The input file or device contains no audio or video streams" and closes

Can you help with this problem?

Provide an answer of your own, or ask Theodore R. Sloper for more information if necessary.

To post a message you must log in.