the permissions of "cdrom0" could not be determined

Asked by Offensive on 2010-05-10

I am using Ubuntu 10.04. I am not able to play Video CD while I can play DVD . When I insert the VCD in the drive, it reads the VCD. Options of playing with various players and other options come on screen. When I select any option to play it shows the following error " could not open location: you might not have permission to open the file". When I opened media/cdrom0 and tried to see the permissions I found the following "the permissions of "cdrom0" could not be determined ".
Then I tried to set the permissions of cdrom0 by enabling root log in. I logged in as root and tried to change permissions, but even then I could not change the permissions.
I tried to copy the VCD to play it on my computer, but i could not copy either.
Please, solve the problem.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Last query:
2010-05-10
Last reply:
2010-05-11

Can you give the output of:

sudo lshw -C disk

If the CD is mounted then you should try unmounting it as this will lock it and create this error.

Offensive,

I'd suggest you try installing mplayer, then running the following command in a terminal:

   mplayer vcd://1

The "1" is track one, if this fails try with 2-5 just to verify that the movie isn't on another track.

SIDE NOTE1: don't log in as root, it's NOT required and Ubuntu was created around the fact that you'd never have too. The fact that you have created a root password slightly lowers your system's security, as previously on one could log in as root - now they could.

SIDE NOTE2: you can't really change the permission on a device (something like /dev/$WHATEVER).

SIDE NOTE3: why is it looking for cdrom0 anyways? "ls -l /dev/cdrom" should show what device "cdrom" is actually pointing too.

Good luck,
George

Tom (tom6) said : #3

Hi :)

Hopefully working through the Medibuntu page might solve this and most other multimedia issues
https://help.ubuntu.com/community/Medibuntu

Please let us know how this is going!
Good luck and regards from
Tom :)

Can you help with this problem?

Provide an answer of your own, or ask Offensive for more information if necessary.

To post a message you must log in.