cannot enable atheros wireless

Asked by Paul Kaneski on 2010-04-23

I just installed ubuntu on my acer aspire one and now I cannot get my Atheros wireless adapter to enable. It is completely unresponsive. I did the following to check for device recognition. It appears to recognise my device but I cannot figure out how to enable it. The physical switch is unresponsive. Please help.

paul@paul-laptop:~$ sudo lshw -C network
[sudo] password for paul:
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 02
       serial: 00:23:8b:6c:0a:a5
       size: 100MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.0.12 latency=0 link=yes multicast=yes port=MII speed=100MB/s
       resources: irq:28 ioport:3000(size=256) memory:51010000-51010fff(prefetchable) memory:51000000-5100ffff(prefetchable) memory:51020000-5103ffff(prefetchable)
  *-network DISABLED
       description: Wireless interface
       product: AR5001 Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wmaster0
       version: 01
       serial: 00:24:2b:4a:fa:80
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=ath5k latency=0 multicast=yes wireless=IEEE 802.11bg
       resources: irq:18 memory:55200000-5520ffff
paul@paul-laptop:~$

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Solved by:
Paul Kaneski
Solved:
2010-04-25
Last query:
2010-04-25
Last reply:
2010-04-24
Book 'em Dano (heymrdjd) said : #1

Type the following commands (copy-paste to the Terminal then hit <enter>) and copy the output to this thread.

cat /etc/lsb-release; sudo iwlist scanning; lspci -nn; lsusb; uname -a; dmesg | grep ound; dmesg | grep witch; iwconfig

Paul Kaneski (akaboulos) said : #2

paul@paul-laptop:~$ cat /etc/lsb-release; sudo iwlist scanning; lspci -nn; lsusb; uname -a;
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.10
DISTRIB_CODENAME=karmic
DISTRIB_DESCRIPTION="Ubuntu 9.10"
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 Scan completed :
          Cell 01 - Address: 00:26:5A:D0:8D:A0
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=70/70 Signal level=-30 dBm
                    Encryption key:on
                    ESSID:"P and M internetting"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000054340f5282
                    Extra: Last beacon: 824ms ago
                    IE: Unknown: 00145020616E64204D20696E7465726E657474696E67
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030106
                    IE: Unknown: 0706555320010B1B
                    IE: Unknown: 200100
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 2A0102
                    IE: Unknown: 32043048606C
                    IE: Unknown: DD180050F2020101020003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C334C101BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 2D1A4C101BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3406001900000000000000000000000000000000000000
                    IE: Unknown: 3D1606001900000000000000000000000000000000000000
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: Unknown: DD7B0050F204104A00011010440001021041000100103B00010310470010565AA94967C14C0EAA8FF349E6F5931110210006442D4C696E6B1023000D442D4C696E6B20526F75746572102400074449522D363135104200046E6F6E651054000800060050F204000110110006442D4C696E6B100800020084103C000101
          Cell 02 - Address: 00:40:05:5B:A5:E7
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=26/70 Signal level=-84 dBm
                    Encryption key:on
                    ESSID:"default"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
                    Mode:Master
                    Extra:tsf=0000009c5956fff1
                    Extra: Last beacon: 908ms ago
                    IE: Unknown: 000764656661756C74
                    IE: Unknown: 010582848B962C
                    IE: Unknown: 030106
                    IE: Unknown: DD0408002800
          Cell 03 - Address: 00:15:E9:61:39:9A
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=20/70 Signal level=-90 dBm
                    Encryption key:on
                    ESSID:"dlink"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              12 Mb/s; 24 Mb/s; 36 Mb/s
                    Bit Rates:9 Mb/s; 18 Mb/s; 48 Mb/s; 54 Mb/s
                    ESSID:""
                    ESSID:""
                    ESSID:""
                    ESSID:""
                    Mode:Master
                    Extra:tsf=0000042682d82181
                    Extra: Last beacon: 6856ms ago
                    IE: Unknown: 0005646C696E6B
                    IE: Unknown: 010882848B960C183048
                    IE: Unknown: 030106
                    IE: Unknown: 050400010A01
                    IE: Unknown: 2A0102
                    IE: Unknown: 32041224606C
                    IE: Unknown: 0000
                    IE: Unknown: 0000
                    IE: Unknown: 0000
                    IE: Unknown: 0000

00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GME Express Memory Controller Hub [8086:27ac] (rev 03)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GME Express Integrated Graphics Controller [8086:27ae] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 [8086:27d0] (rev 02)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 [8086:27d2] (rev 02)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 [8086:27d4] (rev 02)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 [8086:27d6] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 [8086:27c8] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 [8086:27c9] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 [8086:27ca] (rev 02)
00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 [8086:27cb] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller [8086:27cc] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller [8086:27c4] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller [8086:27da] (rev 02)
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
03:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR5001 Wireless Network Adapter [168c:001c] (rev 01)
04:00.0 System peripheral [0880]: JMicron Technology Corp. SD/MMC Host Controller [197b:2382]
04:00.2 SD Host controller [0805]: JMicron Technology Corp. Standard SD Host Controller [197b:2381]
04:00.3 System peripheral [0880]: JMicron Technology Corp. MS Host Controller [197b:2383]
04:00.4 System peripheral [0880]: JMicron Technology Corp. xD Host Controller [197b:2384]
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Linux paul-laptop 2.6.31-20-generic #58-Ubuntu SMP Fri Mar 12 05:23:09 UTC 2010 i686 GNU/Linux
paul@paul-laptop:~$ dmesg | grep ound; dmesg | grep witch; iwconfig
[ 0.912940] ACPI: No dock devices found.
[ 0.963155] pnp: PnP ACPI: found 9 devices
[ 0.998200] pci 0000:02:00.0: BAR 6: no parent found for of device [0xfffe0000-0xffffffff]
[ 0.998211] pci 0000:04:00.0: BAR 6: no parent found for of device [0xffff8000-0xffffffff]
[ 1.873546] isapnp: No Plug & Play device found
[ 1.885439] ehci_hcd 0000:00:1d.7: using broken periodic workaround
[ 1.904255] hub 1-0:1.0: USB hub found
[ 1.904889] hub 2-0:1.0: USB hub found
[ 1.905374] hub 3-0:1.0: USB hub found
[ 1.905837] hub 4-0:1.0: USB hub found
[ 1.906308] hub 5-0:1.0: USB hub found
[ 1.926461] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 1.932374] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 16.368466] lp: driver loaded but no devices found
[ 17.623446] uvcvideo: Found UVC 1.00 device USB 2.0 Camera (0c45:62c0)
[ 17.679865] sdhci-pci 0000:04:00.0: SDHCI controller found [197b:2382] (rev 0)
[ 17.680361] sdhci-pci 0000:04:00.2: SDHCI controller found [197b:2381] (rev 0)
[ 18.242633] ath5k phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)
[ 0.181671] ACPI: EC: non-query interrupt received, switching to interrupt mode
[ 0.696013] ACPI: EC: missing confirmations, switch off interrupt mode.
[ 0.948052] Switched to high resolution mode on CPU 0
[ 0.949188] Switched to high resolution mode on CPU 1
[ 1.456539] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input2
[ 1.512072] ACPI: Lid Switch [LID0]
[ 5.442888] Console: switching to colour frame buffer device 128x37
[ 19.453921] hda-intel: azx_get_response timeout, switching to polling mode: last cmd=0x001f000d
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:""
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          Tx-Power=20 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

paul@paul-laptop:~$

Book 'em Dano (heymrdjd) said : #3

You could try following the instructions here https://help.ubuntu.com/community/WifiDocs/Driver/Atheros or here http://dimitar.me/madwifi-drivers-for-ubuntu-9-10-karmic-koala-or-linux-kernels-2-6-29-and-above/ but first type these commands into a terminal to see if ath_pci is blacklisted on your machine:

 grep -r "ath_pci" /etc/modprobe.d/
netstat -rn (to see if your wireless device sees the router)

Paul Kaneski (akaboulos) said : #4

The wireless is detecting my network and others in the neighbourhood but I can't get it to connect. It repeatedly asks for the password (which I give) and shows that it is trying to connect. I've tried power cycling the modem and router with no success. Others in the house are connected.

I downloaded madwifi 9.4 and extracted the files but I'm not sure what to do with it from there.

Any help is appreciated!

Hi Paul,

I see 3 potential problems with the following Terminal output that you posted:

                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=70/70 Signal level=-30 dBm
                    Encryption key:on
                    ESSID:"P and M internetting"

1) your wireless access point is transmitting on channel 6, but there are 2 other wireless access points who are also transmitting on channel 6 and could be causing wireless interference
2) encryption is enabled on your wireless access point -> may not work in Ubuntu using your wireless card
3) the ESSID of your router "P and M internetting" contains spaces in the name

So I suggest the following changes to see if they help solve the connection issue:

* access the wireless router homepage using a WIRED network connection and then set the following:
* change the wireless transmission frequency to channel 3 or channel 1
* temporarily disable encryption and enable SSID broadcasting on the router
* change the ESSID name to a name without spaces, for example "WAP"

If Ubuntu can access the wireless point this way, try changing one parameter at a time, for example: enable encryption again (using a less complex WPA password for testing purposes) and retest.....

Regards,

Mark

Paul Kaneski (akaboulos) said : #6

In my ignorance I couldn't figure out how to change from channel 6 to 1 or 3, but I did change the name of the network and changed the password to something simpler. It now works like a charm!

Thank you, every one!!!