I can't get Network manager to find vodafone USB mobile broadband stick

Asked by David McCormack on 2010-04-17

I have a USB stick from vodafone (Australia) and the device can not be found in the network manager when setting the network. I've used my mobile phone through a usb connection in the same manner (also vodafone) and it works fine, but the stick needs to be activated (found). Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Solved by:
Cefn
Solved:
2010-05-03
Last query:
2010-05-03
Last reply:
2010-04-26
Marc Stewart (marc.stewart) said : #1

To set up mobile broadband in Ubuntu, you should just need to use the wizard.

Open Network Connections (System > Preferences > Network Connections, or right click the Network Manager applet and click Edit Connections)
Switch to the Mobile Broadband tab.
Click Add.

The wizard will open, and is as simple as picking your country, operator, and plan, then clicking Apply.

That will make your stick available in the Network Manager applet, so you can select and use it.

David McCormack (redwolf) said : #2

Been there, tried that. The device is still not recognised despite going through all the wizard steps.

The device is not being recognised when plugged in for the wizard, or even if you follow all the steps and then click on the Network manager.

Can you give the output of:

lsusb

David McCormack (redwolf) said : #4

Bus 001 Device 007: ID 12d1:1520 Huawei Technologies Co., Ltd.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

David McCormack (redwolf) said : #6

I've just gone into Palimpsest Disk Utility, and I've discovered that the Huawei usb device is being read as a Unpartitioned CD ROM on dev/sr1.

Would the question now be how do we make this accept as a usb device?

I have been all through the pages there and I'm still no closer to making the vodafone stick register as a usb device as opposed to a CD ROM.

Thanks for the try though. It would seem that udev is actively installed, however I can't get anything to change for the better.

There are no results for: ls /dev/ttyUSB*

And my product ID is still: 0x12d1:0x1520 as opposed to 0x12d1:0x1465.

Any further insight would be fantastic.

David McCormack (redwolf) said : #7

Correction, the result for ls /dev/ttyUSB* is ls /dev/ttyUSB0

My Bad...

Is there any model number visible on the outside of the dongle? Knowing what the Huawei model is would be helpful.

I use a Huawei E160 which also has an SD port in it, but it is auto-detected fine by Karmic.

David McCormack (redwolf) said : #9

The model is a Huawei K3765. It too has a Micro SD card slot in it. I had thought that the slot was what was causing the confliction (machine mistaking it for CD ROM), but I'm still fairly new to all of this. Any help or advice greatly appreciated. So far I've pulled the SIM out of the stick and am using it through an old Nokia that I had floating around, and that has been working, but it would be better if I could initialise the USB stick itself.

Did you look into using Vodafone Mobile Connect? This is a .deb package which you should be able to double click on to install, and if it doesn't work, should be fairly straightforward to remove using Synaptic package manager.

http://www.pcurtis.com/ubuntu-mobile.htm#vmc

There's a whole bunch of information elswhere on that page about various modems, including some commentary about turning off the SD card facility using AT (serial modem) commands. Hopefully not too confusing, but you may find some useful avenues to explore...

http://www.pcurtis.com/ubuntu-mobile.htm

David McCormack (redwolf) said : #11

Thanks Cefn, that solved my question.

David McCormack (redwolf) said : #12

Your links led me to a solution from betavine. Everything else that was done was so close, but there was one more package required to make it switch.

mine is still not getting recognized by my system. I dont understand sometimes it runs and sometimes what ever i do, i cant run it. Please help me out. I have a Vodafone mobile connect K3800 and when i plug it in, it gets booted up and shows me the files inside it and the light turns blue on the dongle.
Thanks..