font special characters not shown in e-mail

Asked by Ron Moons on 2010-04-03

Hi,
When I get an html e-mail with special characters they are not shown but I see a square with a number in it (example 0091)
The font -family in the e-mail is arial, sans-serif.
I do not have the font "arial" but I have "sans", and also "serif" but I d'nt know if that is the same as "sans-serif"
Do I need to install a font, and how to do so.

Thanks for your response.
Ron.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Last query:
2010-04-03
Last reply:
2010-04-03
Marc Stewart (marc.stewart) said : #2

You can install Arial (and a few other fonts used in Windows) by opening a terminal (Applications > Accessories > Terminal) and typing:
sudo apt-get install msttcorefonts

Extra info:
Serif and sans-serif are the two basic styles of typefaces: serif faces have little curly bits (serifs) at the end of each stroke, and are the kind typically used in stonemasonry. A common example on computers would be Times New Roman (and Serif in Ubuntu). Sans-serif (meaning without serif) faces have blunt ends. Arial and Sans are both examples of sans-serif typefaces.

Ron Moons (ronmoons) said : #3

This is helpful but not (yet) the solution to my problem.
I did check if the multiverse repository is enabled (yes, it is in Ubuntu 9.10)
Then I installed with Synaptic the ttf-liberation and the ttf-mscorefonts-installer.
After that I run the command "sudo fc-cache -f -v" in a terminal shell and restarted my computer.
I still have the numbers in a square between the text in my html e-mail.
I can sent the e-mail if you want to see.

Ron Moons (ronmoons) said : #4

More information.
When I set the e-mail preference to plain text, I get an html document enclosured.
When I open this, It opens in Mozilla Firefox and then I can see it properly.

Sam_ (and-sam) said : #5

> opens in Mozilla Firefox and then I can see it properly

Firefox, Ubuntu and Evolution usually use UTF-8.
Since I don't use local mail apps, maybe you'll find a setting to switch encoding or some autodetect option.
Or ask sender of mail to use UTF-8 (Unicode).

http://library.gnome.org/users/evolution/stable/
http://en.wikipedia.org/wiki/Character_encoding

Can you help with this problem?

Provide an answer of your own, or ask Ron Moons for more information if necessary.

To post a message you must log in.