Update Manager gives error message that says "Could not download all repository indexes".

Asked by Kari Brandt on 2010-03-15

I am getting an error message that says "Could not download all repository indexes" and refers to network connection and repository address. There is another error message that says "Some index files failed to download, they have been ignored or old ones used instead" These are of course occuring with Update Manager. Please advise and soon.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Last query:
2010-03-16
Last reply:
2010-03-16

Can you give the output of:

sudo apt-get update; lsb_release -a

Thanks

Kari Brandt (calcitykaask) said : #2

How do I sent you a report on what you requested. Please advise

You didn't. I don't read and actively filter emails from here.

Please paste the output text here, as you can see there is no output here so we cannot move forward.

Kari Brandt (calcitykaask) said : #4

kari@kari-desktop:~$ sudo apt-get update; lsb_release -a
[sudo] password for kari:
Building old list of packages... [done]
Building old list of available updates... [done]
Building old list of watched packages... [done]
Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic Release.gpg
Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Translation-en_US
Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/restricted Translation-en_US
Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic Release
Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Packages
Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/restricted Packages
Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Packages
Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/restricted Packages
Err cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Packages
  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Err cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/restricted Packages
  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Get:1 http://security.ubuntu.com karmic-security Release.gpg [189B]
Ign http://security.ubuntu.com karmic-security/main Translation-en_US
Get:2 http://archive.canonical.com karmic Release.gpg [189B]
Ign http://archive.canonical.com karmic/partner Translation-en_US
Ign http://security.ubuntu.com karmic-security/restricted Translation-en_US
Ign http://security.ubuntu.com karmic-security/universe Translation-en_US
Ign http://security.ubuntu.com karmic-security/multiverse Translation-en_US
Hit http://security.ubuntu.com karmic-security Release
Hit http://archive.canonical.com karmic Release
Hit http://security.ubuntu.com karmic-security/main Packages
Hit http://archive.canonical.com karmic/partner Sources
Get:3 http://us.archive.ubuntu.com karmic Release.gpg [189B]
Ign http://us.archive.ubuntu.com karmic/restricted Translation-en_US
Hit http://security.ubuntu.com karmic-security/restricted Packages
Hit http://security.ubuntu.com karmic-security/universe Packages
Hit http://security.ubuntu.com karmic-security/multiverse Packages
Hit http://archive.canonical.com karmic/partner Packages
Ign http://us.archive.ubuntu.com karmic/main Translation-en_US
Ign http://us.archive.ubuntu.com karmic/universe Translation-en_US
Ign http://us.archive.ubuntu.com karmic/multiverse Translation-en_US
Get:4 http://us.archive.ubuntu.com karmic-proposed Release.gpg [189B]
Ign http://us.archive.ubuntu.com karmic-proposed/restricted Translation-en_US
Ign http://us.archive.ubuntu.com karmic-proposed/main Translation-en_US
Ign http://us.archive.ubuntu.com karmic-proposed/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com karmic-proposed/universe Translation-en_US
Get:5 http://us.archive.ubuntu.com karmic-updates Release.gpg [189B]
Ign http://us.archive.ubuntu.com karmic-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com karmic-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com karmic-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com karmic-updates/universe Translation-en_US
Hit http://us.archive.ubuntu.com karmic Release
Hit http://us.archive.ubuntu.com karmic-proposed Release
Hit http://us.archive.ubuntu.com karmic-updates Release
Hit http://us.archive.ubuntu.com karmic/restricted Packages
Hit http://us.archive.ubuntu.com karmic/main Packages
Hit http://us.archive.ubuntu.com karmic/universe Packages
Hit http://us.archive.ubuntu.com karmic/multiverse Packages
Hit http://us.archive.ubuntu.com karmic-proposed/restricted Packages
Hit http://us.archive.ubuntu.com karmic-proposed/main Packages
Hit http://us.archive.ubuntu.com karmic-proposed/multiverse Packages
Hit http://us.archive.ubuntu.com karmic-proposed/universe Packages
Hit http://us.archive.ubuntu.com karmic-updates/restricted Packages
Hit http://us.archive.ubuntu.com karmic-updates/main Packages
Hit http://us.archive.ubuntu.com karmic-updates/multiverse Packages
Hit http://us.archive.ubuntu.com karmic-updates/universe Packages
Fetched 945B in 2s (335B/s)
W: Failed to fetch cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5)/dists/karmic/main/binary-i386/Packages.gz Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

W: Failed to fetch cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5)/dists/karmic/restricted/binary-i386/Packages.gz Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

E: Some index files failed to download, they have been ignored, or old ones used instead.
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic
kari@kari-desktop:~$ kari@kari-desktop:~$ sudo apt-get update; lsb_release -a
kari@kari-desktop:~$: command not found
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic
kari@kari-desktop:~$ [sudo] password for kari:
[sudo]: command not found
kari@kari-desktop:~$ Building old list of packages... [done]
Building: command not found
kari@kari-desktop:~$ Building old list of available updates... [done]
Building: command not found
kari@kari-desktop:~$ Building old list of watched packages... [done]
Building: command not found
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic Release.gpg
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Translation-en_US
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/restricted Translation-en_US
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic Release
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Packages
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/restricted Packages
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Packages
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/restricted Packages
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Err cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Packages
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Please: command not found
kari@kari-desktop:~$ kari@kari-desktop:~$ sudo apt-get update; lsb_release -a
kari@kari-desktop:~$: command not found
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic
kari@kari-desktop:~$ [sudo] password for kari:
[sudo]: command not found
kari@kari-desktop:~$ Building old list of packages... [done]
Building: command not found
kari@kari-desktop:~$ Building old list of available updates... [done]
Building: command not found
kari@kari-desktop:~$ Building old list of watched packages... [done]
Building: command not found
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic Release.gpg
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Translation-en_US
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/restricted Translation-en_US
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic Release
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Packages
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/restricted Packages
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Packages
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/restricted Packages
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Err cdrom://Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5) karmic/main Packages
bash: syntax error near unexpected token `('
kari@kari-desktop:~$ Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Please: command not found
kari@kari-desktop:~$

________________________________
From: actionparsnip <email address hidden>
To: <email address hidden>
Sent: Mon, March 15, 2010 5:56:22 PM
Subject: Re: [Question #104460]: Update Manager gives error message that says "Could not download all repository indexes".

Your question #104460 on yelp in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/yelp/+question/104460

    Status: Open => Needs information

actionparsnip requested for more information:
You didn't. I don't read and actively filter emails from here.

Please paste the output text here, as you can see there is no output
here so we cannot move forward.

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/ubuntu/+source/yelp/+question/104460

You received this question notification because you are a direct
subscriber of the question.

un software sources under the administration menu and untick the install media as a source, if you read the error this is quite clear what is going on.

Once removed, the apt-get / software center will not try and find the CD as a reposiitory.

If your system is command line based you will need to run:

sudo nano /etc/apt/sources.list

and add a '#' character to the line starting

deb cdrom

This will do the same thing

Can you help with this problem?

Provide an answer of your own, or ask Kari Brandt for more information if necessary.

To post a message you must log in.