delete search history

Asked by maria gutierrez on 2010-03-01

I want to delete the history of all the file searches I have done on my laptop, I tried highlighting and then delete, but it's not clearing it.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Last query:
2010-03-05
Last reply:
2010-03-07

What app are you using to search? There are several.

Open a Terminal and type,
gksu gedit /home/<username>/.gconf/apps/gnome-settings/gnome-search-tool/%gconf.xml

then delete all the text beginning in the "<entry name =" until "</entry>. Save the file. That should do it for you.

It doesn't need gksu, the user will be the owner of its own data and have write access so gksu is not needed.

If you were editting a different users file THEN gksu is needed.

You can also make the command directly copy / pastable with:

gedit /home/$USER/.gconf/apps/gnome-settings/gnome-search-tool/%gconf.xml

The $USER bit will be replaced by the shell as the the user editting the file. There are many variables like this in linux

 I need to know how to delete  history on search for files on Ubuntu

--- On Thu, 3/4/10, actionparsnip <email address hidden> wrote:

From: actionparsnip <email address hidden>
Subject: Re: [Question #102844]: delete search history
To: <email address hidden>
Date: Thursday, March 4, 2010, 3:22 PM

Your question #102844 on yelp in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/yelp/+question/102844

actionparsnip proposed the following answer:
It doesn't need gksu, the user will be the owner of its own data and
have write access so gksu is not needed.

If you were editting a different users file THEN gksu is needed.

You can also make the command directly copy / pastable with:

gedit /home/$USER/.gconf/apps/gnome-settings/gnome-search-
tool/%gconf.xml

The $USER bit will be replaced by the shell as the the user editting the
file. There are many variables like this in linux

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/yelp/+question/102844/+confirm?answer_id=2

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/yelp/+question/102844

You received this question notification because you are a direct
subscriber of the question.

yes can you help me step by step, I am using UBUNTU

--- On Fri, 3/5/10, maria gutierrez <email address hidden> wrote:

From: maria gutierrez <email address hidden>
Subject: Re: [Question #102844]: delete search history
To: <email address hidden>
Date: Friday, March 5, 2010, 3:15 AM

Your question #102844 on yelp in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/yelp/+question/102844

    Status: Answered => Open

You are still having a problem:
 I need to know how to delete  history on search for files on Ubuntu

--- On Thu, 3/4/10, actionparsnip <email address hidden>
wrote:

From: actionparsnip <email address hidden>
Subject: Re: [Question #102844]: delete search history
To: <email address hidden>
Date: Thursday, March 4, 2010, 3:22 PM

Your question #102844 on yelp in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/yelp/+question/102844

actionparsnip proposed the following answer:
It doesn't need gksu, the user will be the owner of its own data and
have write access so gksu is not needed.

If you were editting a different users file THEN gksu is needed.

You can also make the command directly copy / pastable with:

gedit /home/$USER/.gconf/apps/gnome-settings/gnome-search-
tool/%gconf.xml

The $USER bit will be replaced by the shell as the the user editting the
file. There are many variables like this in linux

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/yelp/+question/102844/+confirm?answer_id=2

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/yelp/+question/102844

You received this question notification because you are a direct
subscriber of the question.

You received this question notification because you are a direct
subscriber of the question.

What happened when you open the file %gconf.xml

Can you help with this problem?

Provide an answer of your own, or ask maria gutierrez for more information if necessary.

To post a message you must log in.