I have problems to install YADE with Ubuntu 17.1, I do not know if it is Ubuntu or YADE 18. I get an error in the command "qt"

Asked by Noelia Valderrama on 2018-04-12

I would like to install YADE in my laptop, but when I type: from yade import qt
---------------------------------------------------------------------------
ImportError Traceback (most recent call last)
/usr/bin/yade in <module>()
----> 1 from yade import qt

/usr/lib/x86_64-linux-gnu/yade/py/yade/qt/__init__.py in <module>()
      7 if 'YADE_BATCH' in os.environ:
      8 msg += "\nDo not import qt when running in batch mode."
----> 9 raise ImportError(msg)
     10
     11 from PyQt5.QtGui import *

ImportError: Connecting to DISPLAY at Yade startup failed, unable to activate the qt5 interface.

Please help me, is may be something about the installation ?

Thank you!

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu yade Edit question
Assignee:
No assignee Edit question
Last query:
2018-04-12
Last reply:
2018-04-28

What is the output of:

apt-cache policy yade

Thanks

The output is:

ImportError Traceback (most recent call last)
/usr/bin/yade in <module>()
----> 1 from yade import qt

/usr/lib/x86_64-linux-gnu/yade/py/yade/qt/__init__.py in <module>()
      7 if 'YADE_BATCH' in os.environ:
      8 msg += "\nDo not import qt when running in batch mode."
----> 9 raise ImportError(msg)
     10
     11 from PyQt5.QtGui import *

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.