How come Firefox was removed during partial upgrade, when using udate?

Asked by Robert Mills

I used the alert icon for new updates and a partial upgrade was asked. On this process Firefox 3 was removed and when I attempted to reinstall Firefox, it could not be installed. This is the error message:

 firefox-3.0:
  Depends: xulrunner-1.9 (<1.9~b6~) but 1.9~rc1+nobinonly-0ubuntu1~8.04.1 is to be installed,

Apparently the xulrunner needed is not available or is broken? Or has support for Firefox been dropped by Ubuntu?

I am able to use SeaMonkey but sometimes Firefox has to be used because SeaMonkey will not show all web pages.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xulrunner-1.9 Edit question
Assignee:
No assignee Edit question
Solved by:
Robert Mills
Solved:
Last query:
Last reply:
Revision history for this message
Bhavani Shankar (bhavi) said :
#1

Hello Robert:

Its a known problem in ubuntu hardy..

Please ref this thread:

http://ubuntuforums.org/showthread.php?t=746362

Regards

Bhavani Shankar.

Revision history for this message
Robert Mills (rmills764-cyberbsolutions) said :
#2

refreshed all of the packages and then reran updates and it worked.