Cannot suspend or hibernate in Xubuntu

Asked by Greg Toombs on 2012-03-14

uname -a
Linux 3.0.0-16-generic #29-Ubuntu SMP Tue Feb 14 12:48:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/issue
Ubuntu 11.10 \n \l

When I select "Log Out" from the menu, neither hibernate nor suspend appear. When I right-click on the power manager tray icon, they're both grayed out. When I click on Suspend from the session menu, I see a message box with "Failed to suspend session / Suspend failed, no backend supported".

So... how to suspend? I should add that the pm-suspend command works just fine, so this is not a hardware problem.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xubuntu-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Greg Toombs
Solved:
2012-08-31
Last query:
2012-08-31
Last reply:
2012-08-31

Can you give the output of:

cat /etc/lsb-release

Does the system have a make and model?

Greg Toombs (greg-toombs) said : #2

cat /etc/lsb-release:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"

(though odd that that doesn't show up as Xubuntu)

The system is a Toshiba Satellite L500-038.

Do you have the latest BIOS?

Greg Toombs (greg-toombs) said : #4

# dmidecode 2.9
SMBIOS 2.5 present.
22 structures occupying 1287 bytes.
Table at 0x000D8010.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
 Vendor: TOSHIBA
 Version: V2.00
 Release Date: 03/23/2010
 Address: 0xE4390
 Runtime Size: 113776 bytes
 ROM Size: 64 kB
 Characteristics:
  ISA is supported
  PCI is supported
  PC Card (PCMCIA) is supported
  PNP is supported
  BIOS is upgradeable
  BIOS shadowing is allowed
  ESCD support is available
  Boot from CD is supported
  ACPI is supported
  USB legacy is supported
  AGP is supported
  BIOS boot specification is supported
  Targeted content distribution is supported
 BIOS Revision: 2.0
 Firmware Revision: 2.0

Handle 0x0001, DMI type 1, 27 bytes
System Information
 Manufacturer: TOSHIBA
 Product Name: Satellite L500
 Version: PSLS0C-038012
 Serial Number: Y9576714K
 UUID: 9A54535F-CE44-11DE-9A89-002622EC0578
 Wake-up Type: Power Switch
 SKU Number: 012345678912345678912345678
 Family: ABCDEFGHIJKLMNOPQRSTUVWXYZ

Handle 0x0002, DMI type 2, 15 bytes
Base Board Information
 Manufacturer: TOSHIBA
 Product Name: KSWAA
 Version: 1.00
 Serial Number: 0123456789AB
 Asset Tag: Not Specified
 Features: None
 Location In Chassis: Not Specified
 Chassis Handle: 0xFFFF
 Type: Unknown
 Contained Object Handles: 0

Toshiba seems to be offering a 2.10 BIOS. However, I suspect that that isn't the problem, since (again) pm-suspend is working with no problems at all. Regardless, I'll try updating the BIOS and see if it helps.

The newer BIOS may help :)

Greg Toombs (greg-toombs) said : #6

Updated the BIOS. Didn't help. pm-suspend still works fine and xubuntu's suspend is still busted.

I suggest you report a bug

This was an easy fix.

I just did 'sudo apt-get install xfce4-power-manager.

I no longer have any issue about backend supported. Good luck

Greg Toombs (greg-toombs) said : #9

This was actually solved by a kernel update a while back.