xubuntu default terminal size doesnt work

Asked by Peter on 2011-12-13

I have created the file

/home/peter/.config/Terminal/terminalrc

with
MiscDefaultGeometry=97x34

but the terminal still defaults to 80x24
What have I done incorrectly here?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xubuntu-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Peter
Solved:
2011-12-15
Last query:
2011-12-15
Last reply:
2011-12-15
marcus aurelius (adbiz) said : #1

it appears that there are 4 sizes that terminal uses. your setting isn't one of them.
why don't you use one of the 4 that the terminal can be set to?

Peter (nitep) said : #2

That sounds like a plan. What are the 4 sizes?

Thanks Marcus

are you running xfce4-terminal or but gnome-terminal ?

Could also use (I assume xfce4-terminal):

xfce4-terminal --geometry 80x40 --title foo

Also see:
http://www.os-cillation.com/documentation/terminal/C/advanced.html#files-and-env-vars

For options for the rc file.

Peter (nitep) said : #4

Hi Andrew,

xfce4-terminal --geometry 90x40

worked but

xfce4-terminal --geometry 90x40;perl menu

did nothing. What should I have?

Thanks,
Peter

seems to be:

xfce4-terminal --geometry 90x40 -x perl menu

Peter (nitep) said : #6

I am a dummy. I just looked up man xfce4-terminal and saw -x and tried it before coming back here.

Sorry and thanks Andrew.

no probs dude, the semicolon command you gave would have ran the terminal, then executed the next command outside the terminal. Glad you got the gold, and that you learned the value of man pages :)