No title bar in xfce for maximized windows

Asked by Daniel on 2011-10-16

Hi
In xfce (xubuntu 11.10), i miss the good old title bars and their maximize/minimize/close buttons when a window is maximized. Sure there are alternatives: closing is mostly possible by the file menu, sometimes by typing exit, sometimes using a button on the right bottom edge or somehere else - you just have to search for it, and this is annoying. I often use several open windows, move them around, minimized them or want to close them in a fast and unique way.
And the problem with the title bar: if there are 30+ windows in the task bar, you will not be able to recognize anymore which window is the active one. Bad if you have 10 pictures and there name is in the title bar...

I see, it was a design decision from the ubuntu them. But it should be possible to disable this "feature".

How can I get my buttons and title bar back? either integrated in the top xfce bar or back to the window were they were in past versions.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xubuntu-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Daniel
Solved:
2011-10-31
Last query:
2011-10-31
Last reply:
2011-10-18
Israel Dahl (israeldahl) said : #1

Hi, I have the same version of Xubuntu and I have title bars. Are you using compiz? When I used compiz a few times here and there, I would lose the top part as well, unless I had a window decorator (such as gtk-window-decorator which is default for compiz... or emerald, which is not available for 11.10) I enjoyed the desktop cube, but I switched back to a regular Xfce session....

Normally you can go
Applications-Settings-Settings Manager --> Window Manager
And change the look of the bar, and placement of buttons, etc....

And in
Applications-Settings-Settings Manager --> Window Manager Tweaks
You can turn on compositing, etc...

I hope this gives you a place to start..

Daniel (hackie) said : #2

I found another computer now where it works as it's supposed to do. Funnily, this computer has less xfce packages installed because I just switched over from Unity.
The one which does not work was installed 1.5years ago with xubuntu and has much more packages (like theme files), but everything from standard repositories.

Now, with this computer, I was able to compare all settings in control panel - without success :(

I'll add two screenshots - one normal and one with a maximized window

Daniel (hackie) said : #3
Daniel (hackie) said : #4

I just tested metacity instead of xfwm4, both started with --replace option - behaviour of both is the same, so I think it cannot be a problem of their configuration. I have no idea anymore which part of the system is makeing this issue...

Vitor Caipira (vtgaspar) said : #5

Hi, i had a similar problem. In my case i noticed that maximus was marked to open on startup. I solved the problem unchecking it.
i think it happened because i installed gnome-shell, what dont seems to be your case.

Daniel (hackie) said : #6

Thanks. That was the solution! Maximus was installed. I just removed it and after logging in again everything is fine. I didn't know anything about maximus and its function before.

I don't have gnome-shell installed, but gnome-session is installed. I don't know why but maybe I first installed ubuntu instead of xubuntu years ago. I wasn't able to find out when and how maximus was installed (checked /var/log/apt/)

Thanks again. Now my netbook is ready again for travelling :)