xubuntu crashes to log-in screen when trying to resize video

Asked by znbhckcs on 2011-09-16

Hi
I'm using Xubuntu 11.04.
I can watch a video, either in vlc or with parole, but if I try to resize it or go to full screen mode, I'm sent back to the log in screen.

This problem did not occur before, when I was using Ubuntu (I installed a fresh installation of Xubuntu yesterday).

Any help would be appreciated

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xubuntu-meta Edit question
Assignee:
No assignee Edit question
Last query:
2011-09-16
Last reply:
2011-09-17

Have you tried with mplayer?

znbhckcs (znbhckcs) said : #2

Yes. With the same results.

What is the output of:

sudo lshw -C display; lsb_release -a

Thanks

znbhckcs (znbhckcs) said : #4

  *-display UNCLAIMED
       description: VGA compatible controller
       product: CN896/VN896/P4M900 [Chrome 9 HC]
       vendor: VIA Technologies, Inc.
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 01
       width: 32 bits
       clock: 66MHz
       capabilities: pm agp agp-3.0 vga_controller bus_master cap_list
       configuration: latency=32 mingnt=2
       resources: memory:c0000000-dfffffff memory:fd000000-fdffffff memory:fe9f0000-fe9fffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty

Run:

gksudo gedit /etc/X11/xorg.conf and add this text:

Section "ServerLayout"
    Identifier "Xorg Configured"
    Screen 0 "Screen0" 0 0
EndSection

Section "ServerFlags"
    Option "AllowMouseOpenFail" "true"
    Option "AutoAddDevices" "False"
EndSection

Section "Monitor"
    Identifier "Monitor0"
        Option "DPMS" "true"
    HorizSync 24.0 - 96.0 # Warning: This may fry old Monitors
    VertRefresh 48.0 - 72.0 # Very conservative. May flicker.
EndSection

Section "Device"
    Identifier "Card0"
    Driver "vesa"
    VendorName "All"
    BoardName "All"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Card0"
    Monitor "Monitor0"
    DefaultColorDepth 16
    SubSection "Display"
        Depth 1
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 4
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 8
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 15
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 16
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 24
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "DRI"
    Mode 0666
EndSection

Save the new file, close gedit and reboot. If you do not get a desktop then reboot to root recovery mode (Hold shift at boot, select recovery mode then select root) then run:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf_old; reboot

And you will be back where you are now. You will need to mess around with the xorg.conf file til you get a decent display. It seems udev is not picking the display up correctly. It also doesn't help you having a poorly powered video chip but it should be able to do 2D enough to run Ubuntu.

znbhckcs (znbhckcs) said : #8

After creating this xorg.conf file, video did seem to work, but only under vlc with heavy flickering.
Besides, my keyboard has stopped working...

After spending all day trying to get it to work (I tried running xorg -configure and edit it) and getting no where, I decided to give up and try my luck with Kubuntu.

I used to run Ubuntu with no problems, but everything got messed up when I upgraded to 11.04 (Unity and all that).

I suggest you try Ubuntu Classic session at the login screen

Can you help with this problem?

Provide an answer of your own, or ask znbhckcs for more information if necessary.

To post a message you must log in.