UNCLAIMED Wireless Network controller [0280]: Texas Instruments ACX 111 54Mbps Wireless Interface [104c:9066] not working on Toshiba Satellite 1905 in Xubuntu 10.04.1 LTS

Asked by Luis Guzman on 2010-10-11

Hi,

Im new to the LInux environment and I just downloaded Xubuntu 10.04 for my laptop. My laptop is a Toshiba with a P4 2.4Ghz with 512 Ram. The installation was pretty straightforward except for my wireless network card. The card is a PCMCIA Linksys WPC54G. The problem I am having is that when I boot Ubuntu, the PCMCIA card will not turn on its lights and I dont have a wireless network. If I boot in Windows XP, the card functions properly. Could someone guide me to solve this problem?

Thanks in advance,
Luis

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xubuntu-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2010-10-12
Last query:
2010-10-12
Last reply:
2010-10-12
Randall Ross (randall) said : #1

Please update your copy of Xubuntu to include all recent patches and new software. Your WPC54G is based on the Broadcom chipset which only recently started working in Ubuntu. AThe announcement was made here: http://www.omgubuntu.co.uk/2010/09/broadcom-releasing-fully-open-source-driver-wifi-driver/

To update your system, you will need to connect to the net with an ethernet cable, and go to the System: Administration: Update Manager.

Please let me know if this solves the problem (or not) once you're all updated.

Luis Guzman (camaro-sc) said : #2

Hi Randall,

Thanks for you help. I updated the system through the Update Manager and restarted but Im still having the same problem. Is there something else I can do?

Hi,

Please first connect your network card to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1: Open Terminal from "Applications->Accessories->Terminal"

Step 2: Please copy-paste the following command from the https://answers.launchpad.net/ubuntu website in Firefox into the Linux Terminal. Do NOT copy-paste from the Email message into the Terminal, as that will only copy PART of the command. The command STARTS with the word sudo and ENDS with the word restart. So please copy-paste the ENTIRE command below from Firefox into a Terminal, press <enter>, then enter password when sudo asks for password, then press enter again.

Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the command written on the page. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl|lbtf|ndiswrapper|NPE|ound|prism|rtl|rt2|rt3|usb|witch|wl'; iwconfig; grep b43 /etc/modprobe.d/*; grep wl /etc/modprobe.d/*; sudo hwinfo --netcard ; sudo lsmod; cat /var/lib/NetworkManager/NetworkManager.state; sudo /etc/init.d/networking restart

Step 3: Please post results (copy/paste terminal output) on this thread. The troubleshooters here need to see the full Terminal output from running the above command.

Regards,

Mark

Luis Guzman (camaro-sc) said : #4

Hi Mark,

Here is the output.

luis@ubuntu:~$ sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl|lbtf|ndiswrapper|NPE|ound|prism|rtl|rt2|rt3|usb|witch|wl'; iwconfig; grep b43 /etc/modprobe.d/*; grep wl /etc/modprobe.d/*; sudo hwinfo --netcard ; sudo lsmod; cat /var/lib/NetworkManager/NetworkManager.state; sudo /etc/init.d/networking restart
[sudo] password for luis:
Hit http://security.ubuntu.com lucid-security Release.gpg
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_US
Hit http://us.archive.ubuntu.com lucid Release.gpg
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/main Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_US
Hit http://security.ubuntu.com lucid-security Release
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com lucid-updates Release.gpg
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com lucid Release
Hit http://us.archive.ubuntu.com lucid-updates Release
Hit http://security.ubuntu.com lucid-security/main Packages
Hit http://us.archive.ubuntu.com lucid/main Packages
Hit http://us.archive.ubuntu.com lucid/restricted Packages
Hit http://us.archive.ubuntu.com lucid/main Sources
Hit http://us.archive.ubuntu.com lucid/restricted Sources
Hit http://us.archive.ubuntu.com lucid/universe Packages
Hit http://us.archive.ubuntu.com lucid/universe Sources
Hit http://security.ubuntu.com lucid-security/restricted Packages
Hit http://security.ubuntu.com lucid-security/main Sources
Hit http://security.ubuntu.com lucid-security/restricted Sources
Hit http://security.ubuntu.com lucid-security/universe Packages
Hit http://us.archive.ubuntu.com lucid/multiverse Packages
Hit http://us.archive.ubuntu.com lucid/multiverse Sources
Hit http://us.archive.ubuntu.com lucid-updates/main Packages
Hit http://us.archive.ubuntu.com lucid-updates/restricted Packages
Hit http://us.archive.ubuntu.com lucid-updates/main Sources
Hit http://us.archive.ubuntu.com lucid-updates/restricted Sources
Hit http://us.archive.ubuntu.com lucid-updates/universe Packages
Hit http://us.archive.ubuntu.com lucid-updates/universe Sources
Hit http://us.archive.ubuntu.com lucid-updates/multiverse Packages
Hit http://security.ubuntu.com lucid-security/universe Sources
Hit http://security.ubuntu.com lucid-security/multiverse Packages
Hit http://security.ubuntu.com lucid-security/multiverse Sources
Hit http://us.archive.ubuntu.com lucid-updates/multiverse Sources
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
hwinfo is already the newest version.
grep is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  *-network
       description: Ethernet interface
       product: 82801BA/BAM/CA/CAM Ethernet Controller
       vendor: Intel Corporation
       physical id: 8
       bus info: pci@0000:02:08.0
       logical name: eth0
       version: 03
       serial: 00:02:3f:7d:7c:cc
       size: 100MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI duplex=full firmware=N/A ip=192.168.1.73 latency=66 link=yes maxlatency=56 mingnt=8 multicast=yes port=MII speed=100MB/s
       resources: irq:11 memory:e8104000-e8104fff ioport:4000(size=64)
  *-network UNCLAIMED
       description: Network controller
       product: ACX 111 54Mbps Wireless Interface
       vendor: Texas Instruments
       physical id: 1
       bus info: pci@0000:07:00.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm cap_list
       configuration: latency=0
       resources: memory:2c020000-2c021fff memory:2c000000-2c01ffff
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

auto lo
iface lo inet loopback

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.1 LTS"
00:00.0 Host bridge [0600]: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge [8086:1a30] (rev 04)
00:01.0 PCI bridge [0604]: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge [8086:1a31] (rev 04)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev 05)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801BA ISA Bridge (LPC) [8086:2440] (rev 05)
00:1f.1 IDE interface [0101]: Intel Corporation 82801BA IDE U100 Controller [8086:244b] (rev 05)
00:1f.2 USB Controller [0c03]: Intel Corporation 82801BA/BAM USB Controller #1 [8086:2442] (rev 05)
00:1f.3 SMBus [0c05]: Intel Corporation 82801BA/BAM SMBus Controller [8086:2443] (rev 05)
00:1f.4 USB Controller [0c03]: Intel Corporation 82801BA/BAM USB Controller #1 [8086:2444] (rev 05)
00:1f.5 Multimedia audio controller [0401]: Intel Corporation 82801BA/BAM AC'97 Audio Controller [8086:2445] (rev 05)
00:1f.6 Modem [0703]: Intel Corporation 82801BA/BAM AC'97 Modem Controller [8086:2446] (rev 05)
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon Mobility M6 LY [1002:4c59]
02:00.0 CardBus bridge [0607]: O2 Micro, Inc. OZ6933/711E1 CardBus/SmartCardBus Controller [1217:6933] (rev 01)
02:00.1 CardBus bridge [0607]: O2 Micro, Inc. OZ6933/711E1 CardBus/SmartCardBus Controller [1217:6933] (rev 01)
02:08.0 Ethernet controller [0200]: Intel Corporation 82801BA/BAM/CA/CAM Ethernet Controller [8086:2449] (rev 03)
02:0a.0 FireWire (IEEE 1394) [0c00]: Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link) [104c:8023]
07:00.0 Network controller [0280]: Texas Instruments ACX 111 54Mbps Wireless Interface [104c:9066]
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
H/W path Device Class Description
=======================================================
                             system Satellite 1905
/0 bus BTR20
/0/0 memory 95KiB BIOS
/0/4 processor Intel(R) Pentium(R) 4 CPU 2.40GHz
/0/4/8 memory 8KiB L1 cache
/0/4/9 memory 512KiB L2 cache
/0/a memory 512KiB L3 cache
/0/15 memory 512MiB System Memory
/0/15/0 memory 256MiB DIMM SDRAM Synchronous
/0/15/1 memory 256MiB DIMM SDRAM Synchronous
/0/15/2 memory DIMM SDRAM Synchronous [empty]
/0/100 bridge 82845 845 [Brookdale] Chipset Host Bridge
/0/100/1 bridge 82845 845 [Brookdale] Chipset AGP Bridge
/0/100/1/0 display Radeon Mobility M6 LY
/0/100/1e bridge 82801 PCI Bridge
/0/100/1e/0 bridge OZ6933/711E1 CardBus/SmartCardBus Controller
/0/100/1e/0.1 bridge OZ6933/711E1 CardBus/SmartCardBus Controller
/0/100/1e/8 eth0 network 82801BA/BAM/CA/CAM Ethernet Controller
/0/100/1e/a bus TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
/0/100/1f bridge 82801BA ISA Bridge (LPC)
/0/100/1f.1 scsi0 storage 82801BA IDE U100 Controller
/0/100/1f.1/0 /dev/sda disk 40GB IC25N040ATCS04-0
/0/100/1f.1/0/1 /dev/sda1 volume 37GiB Windows NTFS volume
/0/100/1f.1/1 /dev/cdrom disk DVD-ROM SD-R2212
/0/100/1f.2 bus 82801BA/BAM USB Controller #1
/0/100/1f.3 bus 82801BA/BAM SMBus Controller
/0/100/1f.4 bus 82801BA/BAM USB Controller #1
/0/100/1f.5 multimedia 82801BA/BAM AC'97 Audio Controller
/0/100/1f.6 communication 82801BA/BAM AC'97 Modem Controller
/0/1 network ACX 111 54Mbps Wireless Interface
/1 power PA3173U
/2 system
Linux ubuntu 2.6.32-25-generic #44-Ubuntu SMP Fri Sep 17 20:26:08 UTC 2010 i686 GNU/Linux
[ 0.021126] SMP alternatives: switching to UP code
[ 0.129180] ACPI: No dock devices found.
[ 0.135985] usbcore: registered new interface driver usbfs
[ 0.136028] usbcore: registered new interface driver hub
[ 0.136067] usbcore: registered new device driver usb
[ 0.136594] Switching to clocksource tsc
[ 0.163393] pnp: PnP ACPI: found 11 devices
[ 0.199977] pci 0000:02:08.0: Firmware left e100 interrupts enabled; disabling
[ 0.232625] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
[ 0.232673] ACPI: Lid Switch [LID]
[ 0.235496] Switching to clocksource acpi_pm
[ 0.279949] usb usb1: configuration #1 chosen from 1 choice
[ 0.279993] hub 1-0:1.0: USB hub found
[ 0.280772] usb usb2: configuration #1 chosen from 1 choice
[ 0.280812] hub 2-0:1.0: USB hub found
[ 0.342661] device-mapper: multipath: version 1.1.0 loaded
[ 0.342670] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 0.347357] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 0.921817] isapnp: No Plug & Play device found
[ 1.394248] e100: eth0: e100_probe: addr 0xe8104000, irq 11, MAC addr 00:02:3f:7d:7c:cc
[ 25.855808] lp: driver loaded but no devices found
[ 26.180699] found SMC SuperIO Chip (devid=0x5a rev=00 base=0x002e): LPC47N227
[ 26.854009] yenta_cardbus 0000:02:00.0: CardBus bridge found [1179:ff00]
[ 26.981612] yenta_cardbus 0000:02:00.1: CardBus bridge found [1179:ff00]
[ 27.650861] platform radeon_cp.0: firmware: requesting radeon/R100_cp.bin
[ 28.533128] Console: switching to colour frame buffer device 128x48
[ 31.878318] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 101.816174] e100: eth0 NIC Link is Up 100 Mbps Full Duplex
[ 101.816333] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 112.692044] eth0: no IPv6 routers present
lo no wireless extensions.

eth0 no wireless extensions.

/etc/modprobe.d/blacklist.conf:# replaced by b43 and ssb.
/etc/modprobe.d/blacklist-watchdog.conf:blacklist twl4030_wdt
23: PCI 208.0: 0200 Ethernet controller
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_8086_2449
  Unique ID: rBUF.cAirZVzw9MD
  Parent ID: 6NW+.92zbjSp4ZgF
  SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:02:08.0
  SysFS BusID: 0000:02:08.0
  Hardware Class: network
  Model: "Toshiba America Info PRO/100 VE Network Connection"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x2449 "82801BA/BAM/CA/CAM Ethernet Controller"
  SubVendor: pci 0x1179 "Toshiba America Info Systems"
  SubDevice: pci 0xff01 "PRO/100 VE Network Connection"
  Revision: 0x03
  Driver: "e100"
  Driver Modules: "e100"
  Device File: eth0
  Memory Range: 0xe8104000-0xe8104fff (rw,non-prefetchable)
  I/O Ports: 0x4000-0x4fff (rw)
  IRQ: 11 (419 events)
  HW Address: 00:02:3f:7d:7c:cc
  Link detected: yes
  Module Alias: "pci:v00008086d00002449sv00001179sd0000FF01bc02sc00i00"
  Driver Info #0:
    Driver Status: e100 is active
    Driver Activation Cmd: "modprobe e100"
  Driver Info #1:
    Driver Status: eepro100 is not active
    Driver Activation Cmd: "modprobe eepro100"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #12 (PCI bridge)

25: PCI 700.0: 0280 Network controller
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_104c_9066
  Unique ID: aK5u.nVq8cakcbk3
  Parent ID: 2Oa+.Ol+fDF6JE75
  SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:02:00.1/0000:07:00.0
  SysFS BusID: 0000:07:00.0
  Hardware Class: network
  Model: "Linksys WPC54G Ver.2 802.11G PC Card"
  Vendor: pci 0x104c "Texas Instruments"
  Device: pci 0x9066 "ACX 111 54Mbps Wireless Interface"
  SubVendor: pci 0x1737 "Linksys"
  SubDevice: pci 0x0033 "WPC54G Ver.2 802.11G PC Card"
  Memory Range: 0x2c020000-0x2c021fff (rw,non-prefetchable,disabled)
  Memory Range: 0x2c000000-0x2c01ffff (rw,non-prefetchable,disabled)
  IRQ: 11 (419 events)
  Module Alias: "pci:v0000104Cd00009066sv00001737sd00000033bc02sc80i00"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #22 (CardBus bridge)
Module Size Used by
fbcon 35102 71
snd_intel8x0 25588 6
tileblit 2031 1 fbcon
font 7557 1 fbcon
snd_ac97_codec 100646 1 snd_intel8x0
bitblit 4707 1 fbcon
ac97_bus 1002 1 snd_ac97_codec
softcursor 1189 1 bitblit
snd_pcm_oss 35308 0
vga16fb 11385 0
snd_mixer_oss 13746 3 snd_pcm_oss
vgastate 8961 1 vga16fb
snd_pcm 70694 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy 1338 0
snd_seq_oss 26726 0
snd_seq_midi 4557 0
snd_rawmidi 19056 1 snd_seq_midi
snd_seq_midi_event 6003 2 snd_seq_oss,snd_seq_midi
radeon 675160 2
snd_seq 47263 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
pcmcia 30784 0
ttm 49943 1 radeon
snd_timer 19098 2 snd_pcm,snd_seq
drm_kms_helper 29297 1 radeon
snd_seq_device 5700 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
yenta_socket 20408 3
drm 162409 4 radeon,ttm,drm_kms_helper
rsrc_nonstatic 10015 1 yenta_socket
i2c_algo_bit 5028 1 radeon
pcmcia_core 32964 3 pcmcia,yenta_socket,rsrc_nonstatic
snd 54148 18 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
intel_agp 24119 1
joydev 8708 0
soundcore 6620 3 snd
agpgart 31724 3 ttm,drm,intel_agp
snd_page_alloc 7076 2 snd_intel8x0,snd_pcm
ppdev 5259 0
shpchp 28820 0
parport_pc 25962 1
psmouse 63245 0
irda 186556 0
serio_raw 3978 0
crc_ccitt 1339 1 irda
lp 7060 0
parport 32635 3 ppdev,parport_pc,lp
ohci1394 26950 0
e100 28211 0
ieee1394 81181 1 ohci1394
mii 4381 1 e100
floppy 53016 0

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
 * Reconfiguring network interfaces... Ignoring unknown interface eth0=eth0.
                                                                                             [ OK ]
luis@ubuntu:~$

Thanks for your help,

Luic

You have the following wireless chipset installed:

Wireless Network controller [0280]: Texas Instruments ACX 111 54Mbps Wireless Interface [104c:9066]

Unfortunately, this card is a real pain to get working in Ubuntu. It is not really supported anymore in current versions of Ubuntu and the documentation on the Ubuntu forums is very old.

If you are ready for the challenge, you could try the following driver installation procedure:

http://georgia.ubuntuforums.org/showthread.php?t=324148

Or you could choose (buy) an Ubuntu-compatible wireless USB adapter here:

http://linuxhcl.com/browse/search?offset=0&category=25&manufacturer=&rating=5&os=1&order-by=rating-desc&worksoutofthebox=on&keywords=

Luis Guzman (camaro-sc) said : #6

Hi Mark,

I was able to get the card working with the driver installation procedure you linked. It was pretty straightforward and didnt take more than 10 minutes to get everything working properly.

Thanks a lot,
Luis

Luis Guzman (camaro-sc) said : #7

Thanks Mark Rijckenberg, that solved my question.