I cant find the bar

Asked by Ahmed Hamdy on 2010-02-09

I am using linux xubuntu and I cant find the bar which was on the top of the screen where there were the applications menu and the places menu and the firefox icon and the help icon and i cant find the bar where there is the workspaces which is in the end of the screen so on my desktop there is only the (home ,file system ,trash and floppy drive) icons .
so what can i do please help because i have started to use linux since about 2 days and i dont want to hate it like when i hate the windows before.
PLEASE HELP.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xubuntu-meta Edit question
Assignee:
No assignee Edit question
Last query:
2010-02-09
Last reply:
2010-02-20

Right click the desktop and select add panel, add the panel to the top of the screen

You can now right click the new panel and select add item, you can then add anything you like to the panel and move it to where you wish, if you want application shortcuts there simply drag them from the menu to the panel and it will be added.

Once you have added all the things you wish on the panel, right click each item and select "lock" so that it stays put.

Ahmed Hamdy (ahmed95-theghost) said : #2

when i right click on the desktop there is no add panel and when i try to open the panel from the settings it doesn't open.
SO WHAT SHOULD I DO ,PLEASE HELP !

Ahmed Hamdy (ahmed95-theghost) said : #3

and this is a screen shot of my desktop now http://i48.tinypic.com/99pf14.png

GREG T. (ubuntuer) said : #4

Alt-F2, type in xfce4-panel

gconftool – -recursive-unset /apps/panel
(Remember: There should be no spaces between the two dashes before shutdown.)
Then enter the next command:
rm -rf ~/.gconf/apps/panel
And enter one more command:
pkill gnome-panel
That's it!

Wim (launchpad-xs4all) said : #5

The disappearance of the Application menu is often caused by the sudden ending of the browser Firefox, e.g. by shutting down a PC while Firefox is running.

There is a way to get ik back:

First close all programs, so you will only see the Desktop.

Simultaniously press the key-combination <Ctrl-Esc> which will open the Applications-menu
An other way to open this menu is to move your mouse-pointer to an empty place on your desktop and press the Right_Mouse_Button.

In this Application-menu, go to >Accesoires
Select (and start) a Terminal.
In this terminal give the command:

 /usr/bin/xfce4-panel &

The menu on top is here again...
(*)
From this menu, start Firefox; when started, close Firefox again.
Wait some moments...

Now shutdown your PC the normal way, and reboot.

If this second time this menu still is gone, then repeat all actions until you are at (*)...
The menu is there, and the terminal-window is still open.
Be sure there is NO program active other than these! Now just power down the PC by disconnecting the power_cord (a hard shut down).
Reboot, log in, and shut down the normal way.

Hopes this solves your problem.
A hint:
always first quit Firefox, then wait a moment, and after that you can shut down the PC.

Keep enjoying xUbuntu!

Can you help with this problem?

Provide an answer of your own, or ask Ahmed Hamdy for more information if necessary.

To post a message you must log in.