Desktop problem with Ubuntu Server 10.04

Asked by Kerry Hayes on 2010-09-12

Desktop will not start when Ubuntu Server 10.04 is booted. When attempting "startx" is says it is not loaded and to use aptitude. When "apt-get" is performed from package "xinit" is says package is not loaded. ????
How to start the desktop?

Question information

English Edit question
Ubuntu xterm Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

Why did you install the server OS when you obviously wanted a desktop system? I suggest you download the desktop ISO,MD5 test it, burn it as slowly as possible, After checking the CD for defects, install it.

The whole ENTIRE idea behind the server install is that it doesn't have an X server.This is not only to reduce the impact of the X server on resources but also for security as there will be less processes running.
You can run the server apps on the desktop system but if you need a UI to configure stuff then the desktop system should be used.

Kerry Hayes (kthaye2) said : #3

I understand the idea behind the desktop, e.g. security, less process time, etc. the desktop started the first time i loaded it but since reloading it it won't. am trying to get a feel for the system and command line is also time consuming. it has been loaded as a virtual server on oracle's VirtualBox. what i can't understand is why it used to work and now it doesn't and also why xinit is not loaded as a package.
I already have the client version loaded.

if you read /var/log/Xorg.0.log

It may give clues

Kerry Hayes (kthaye2) said : #5

No such file or directory...

Then you can install ubuntu-desktop. You now have a bodged equivelant of the desktop system.

Kerry Hayes (kthaye2) said : #7

That has already been tried too without success...

Best zvacet (ivicakolic) said : #8

sudo tasksel install ubuntu-desktop

That should install ubuntu-desktop and you will have GUI.

Kerry Hayes (kthaye2) said : #9

yes, this time it worked. i had tried that several times before with no success but after a total reinstall it did work.