red screen of death installing u.12.10

Asked by don on 2013-01-06

I'm trying to install ubuntu 12.10 on a P4, 2.4 GHz, 1G RAM ASUS PC. I have tried;
-fresh install u12.10 on blank H/D
-fresh install of WIN_XP with device drivers then u12.10
-install from u12.10 bootable DVD
-install from u12.10 bootable USB drive

All have gotten stuck in a 'red screen of death' cycle where a blank red screen appears followed by a blank screen.
What is going on here and how to fix this?
Thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-sis Edit question
Assignee:
No assignee Edit question
Solved by:
don
Solved:
2013-01-10
Last query:
2013-01-10
Last reply:
2013-01-07

What video chip do you use?

Thanks

don (e9x6-don) said : #2

Thanks for your reply.
My PC has the SiS AGP. It supports 1024 x 768 res. with 32M RAM.
Yes, I think this is a video driver problem.
I'm installing ubuntu for the first time and don't know how to load the correct driver, if required.

Add the boot optIon:

nomodeset

don (e9x6-don) said : #4

I booted up the PC and got a first dual-boot option and choose u then got the second dual-boot option screen and tried the u with recover mode. There was not a place to enter the nomodeset option.

So, I put the u install DVD into the drive and rebooted.
I selected the F6 options and nomodeset

I started with the u12.10 screen and switched back and forth between two video modes; one was blank and the other the red screen. Turning off the power was the only way to stop this cycle.

All suggestions are welcome. Thanks.

don (e9x6-don) said : #5

I found the problem!
I opened the BIOS and disabled the on-board SiS VGA.
I installed a PCI VGA bd. from nvidia, FX5500.
This video bd. is compatible with u12.10.