Argh, resolution problems (max: 800x600)

Asked by Lamperouge on 2011-03-06

Hello everyone. I know that a lot of people have asked this question before, but I'm literally tearing my hair out trying to solve this on my own and I just seem to be going in circles. I'm a complete newbie to not only Ubuntu/ Linux systems but computing in general, so if you guys could guide me through this step-by-step like a child, I'd really appreciate it.

Now, as I'm sure you've guessed, I'm having some problems with my resolution. Basically when I go to System --->Preferences --->Monitors, my system does not detect *ANYTHING*. No monitors, no drivers, e.t.c. The most I can get is a 800 x 600 screen and some very choppy graphics (by "choppy" I mean stuff doesn't look anywhere near as nice as an Ubuntu system should look like). I would love for my system to have a 1240x1024 resolution, and I know that my monitor is capable of running it... *confused face*

Info on what I'm running:

Basically I'm running Ubuntu 10.10 alongside WIndows 7 on a dual operating system. Ubuntu takes up around 17 GB of my 250GB drive. Ubuntu is now my main operating system. I've got a ASUS X5DC laptop.

This is what I get when I enter the command "udo lshw -C video"
"*-display UNCLAIMED
       description: VGA compatible controller
       product: 771/671 PCIE VGA Display Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 10
       width: 32 bits
       clock: 66MHz
       capabilities: pm agp agp-3.0 vga_controller cap_list
       configuration: latency=0
       resources: memory:d0000000-dfffffff memory:fe9e0000-fe9fffff ioport:dc00(size=128)"

Don't know if that helps you guys at all. I'm completely useless at computing, though I'd really love to learn.

x

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-sis Edit question
Assignee:
No assignee Edit question
Last query:
2011-03-06
Last reply:
2011-03-06

yeah these things can need an xorg.conf file. I doubt you will get 3D accelleration but we can get you a better res.

If you run:

gksudo gedit /etc/X11/xorg.conf

add the below text:

Section "Device"
       Identifier "Device0"
       Driver "sis"
       VendorName "Silicon Integrated Systems [SiS]"
       BoardName "771/671 PCIE VGA Display Adapter"
       Option "EnableSiSCtrl" "yes"
       Option "DRI" "off"
EndSection

Section "Screen"
       Identifier "Screen0"
       Device "Device0"
       Monitor "Monitor0"
       DefaultDepth 24
       SubSection "Display"
               Viewport 0 0
               Depth 24
               Modes "1240x1024"
       EndSubSection
EndSection

Section "ServerLayout"
 Identifier "X.org Configured"
 Screen 0 "Screen0" 0 0
EndSection

Section "Monitor"
 Identifier "Monitor0"
 VendorName "Plug and play"
 ModelName "Plug and play"
 HorizSync 31.5-90
 VertRefresh 60
 Option "PreferredMode" "1240x1024"
EndSection

Save the file and close gedit, reboot to test. If you don't get a display then reboot and hold shift, select recovery mode, then select root. You can now run:

mv /etc/X11/xorg.conf mv /etc/X11/xorg.conf_old

Then reboot

NOTE: The X in X11 is CAPITALIZED. Linux is extremely case sensitive so stay accurate.

Can you help with this problem?

Provide an answer of your own, or ask Lamperouge for more information if necessary.

To post a message you must log in.