Need to add higher screen resolutions

Asked by Mark Mueller on 2011-02-12

I just installed Ubuntu 10.01 on my very old Asus P4S533MX Motherboard with built in video. Only shows max video of 800x600 and I know monitor/board capable of at least 1028 x 780 I've tried to read through threads on this subject but nervous about adding/editing Xorg.conf file with correct code information specific to my graphic driver. I did get output of following when running "sudo lshw -C display" on Terminal. Can't seem to find any Linux drivers on Asus site for this Mobo.

Can someone give me the correct code to input into Xorg.conf?

*-display UNCLAIMED
       description: VGA compatible controller
       product: 65x/M650/740 PCI/AGP VGA Display Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 32 bits
       clock: 66MHz
       capabilities: pm agp agp-2.0 vga_controller cap_list
       configuration: latency=0
       resources: memory:f0000000-f7ffffff memory:e7800000-e781ffff ioport:d800(size=128)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-sis Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Mueller
Solved:
2011-02-12
Last query:
2011-02-12
Last reply:
2011-02-12

Section "Device"
Identifier "Silicon Integrated Systems (SiS) 65x/M650/740 PCI/AGP VGA Display Adapter"
Driver "sis"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Plug and play"
Option "DPMS"
HorizSync 30-69
VertRefresh 50-120
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Silicon Integrated Systems (SiS) 65x/M650/740 PCI/AGP VGA Display Adapter"
Monitor "Plug and play"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection

Section "DRI"
Mode 0666
EndSection

Run:

gksudo gedit /etc/X11/xorg.conf

add the text above to the file, save the new file and reboot. If you get no desktop, reboot and hold shift, select recovery mode then select root then run:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf_old; reboot

And you will be back where you are

Mark Mueller (msmueller) said : #2

Actionparsnip:

Brilliant! Your instructions were perfect and I was able to increase my resolution to the highest option. Thank you for your fast and succinct response to my questions.

Good day...

ok cool, basically your monitor sucks and isn't giving EDID like it's supposed to. Usually udev picks stuff up but your system isn't getting the information it needs, so you need to tell it.

I STRONGLY advise you make a copy of that file somewhere off your PC. If you need to reinstall you can just copy back the file.