Screen resolution in 10.04

Asked by David Wake on 2010-06-25

I have just upgraded from 9.10 to 10.04 LTS on my Advent 5313 laptop.
My screeen resolution has gone back to 800X600 as a maximum.
I had this problem when I installed 9.10 (my very first experience of Ubuntu) but a friend managed to correct it to a higher resolution. He is not available anymore so can anyone help?
Thanks in advance

P.S. I'm looking for 1024X768 as a minimum

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-sis Edit question
Assignee:
No assignee Edit question
Last query:
2010-06-26
Last reply:
2010-06-26

Can you give the output of:

sudo lshw -C display

Thanks

David Wake (djwake) said : #2

Here it is

david@david-laptop:~$ sudo lshw -c display
  *-display UNCLAIMED
       description: VGA compatible controller
       product: 771/671 PCIE VGA Display Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 10
       width: 32 bits
       clock: 66MHz
       capabilities: pm agp agp-3.0 cap_list
       configuration: latency=0
       resources: memory:c0000000-cfffffff(prefetchable) memory:b0000000-b001ffff ioport:9000(size=128)
david@david-laptop:~$

OK, answer a few questions

1) Video card: nvidia, ati or intel?
2) Monitor type: LCD or CRT

If CRT
 3) a) horizontal sync rate (something like 30-107)
     b) vertical refresh rate (something like 48-120)

Those last questions are important and you can find them in the manual.

David Wake (djwake) said : #4

Definitely LCD (it's a laptop)

How do I find out the video card details?

So you have a sis card.
You have to edit (or create if there isn't one) a file like this one

http://ubuntuone.com/p/81n/

Edit vertical and horizontal refresh rates and the desired VALID resolutions (1024x768 800x600), then rename it xorg.conf and copy it to

/etc/X11/

Sorry I did not read the message. I updated the file

http://ubuntuone.com/p/81o/

David Wake (djwake) said : #8

I feel so stupid!!

I have created the xorg.conf file but don't understand how to edit it as your post suggests.

Also, as I am asking these questions on a Windows machine then transferring the results, via a memory stick, to my linux machine, do I have any worries about file extensions? It was saved as xorg.conf.odt but I've just changed it to xorg.conf without he odt extension.

Make sense??

Really appreciate the help!

David Wake (djwake) said : #9

Having applied the change in your last message, I can no longer get anything - when I restart, all I get is lots of purple lines!!

HELP!!!

You can boot to root recovery mode and rename the xorg.conf file and reboot

Can you give the conternt of the renamed file and we can advise

thanks

David Wake (djwake) said : #11

Sorry how do I do this?
I switch on and all I get is lots of lines!

Hold shift at boot, select recovery mode then select root

then run:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf_old

then reboot

once on the desktop run:

gedit /etc/X11/xorg.conf_old

and give the output here

Thanks.

David Wake (djwake) said : #13

I got to the select recovery mode bit OK then the screen went wild - lots of blue and red and white lines!

Haven't been able to select root as you suggested

Boot with a live CD or live USB stick.

Vu Do Quynh (vu-do-quynh) said : #15

HI,

When you edited the xorg.conf file you probably used OpenOffice.org as the file was saved with ODT extension. This is not the good format as xorg.conf is a plain text file format while ODT is actually a zip compressed file (containing XML and other files).

You need to create/edit xorg.conf with a plain text editor (like notepad under Windows) or gedit, etc.

David Wake (djwake) said : #16

No joy!

Perhaps I'll pay my money and stick with Windows...........it just bloody works!

An answer I never thought I'd give!

For the other readers with same issue:

Here the content of the file to put into /etc/X11/xorg.conf suggested from Federico:

 Section "Device"
  Identifier "Builtin Default sis Device 0"
  Driver "sis"
 EndSection
 Section "Screen"
  Identifier "Builtin Default sis Screen 0"
  Device "Builtin Default sis Device 0"
  SubSection "Display"
   Viewport 0 0
   Depth 24
   Modes "1024x768" "800x600"
  EndSubSection
 EndSection
 Section "ServerLayout"
  Identifier "Builtin Default Layout"
  Screen "Builtin Default sis Screen 0"
 EndSection

Please open a terminal from Application→Accessories→Terminal and type:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old

gksudo gedit /etc/X11/xorg.conf

Then copy the above contents, save and close and reboot your pc.

Try this:

gksudo gedit /etc/X11/xorg.conf

Paste this code, save the new file then reboot:

 Section "Device"
  Identifier "Builtin Default sis Device 0"
  Driver "sis"
 EndSection

Section "Monitor"
 Identifier "Plug and play"
 VendorName "unknown"
 ModelName "unknown"
 Option "DPMS"
 HorizSync 30.0 - 75.0
 VertRefresh 50.0 - 70.0
EndSection

 Section "Screen"
  Identifier "Builtin Default sis Screen 0"
  Device "Builtin Default sis Device 0"
  Monitor "Plug and play"
  SubSection "Display"
   Viewport 0 0
   Depth 24
   Modes "1024x768" "800x600"
  EndSubSection
 EndSection

 Section "ServerLayout"
  Identifier "Builtin Default Layout"
  Screen 0 "Screen" 0 0
 EndSection

Can you help with this problem?

Provide an answer of your own, or ask David Wake for more information if necessary.

To post a message you must log in.