video tests (all) fail when running system testing ubuntu 10.10 & ibm t23

Asked by Chuck

I have not been able to have a single game work from the Ubuntu software Center. The System Tests for video crashes( system- adminstration-system test) does not function but flashes some B.S. and return to the main desktop picture.

 I am using ver. 10.10. It is up to date. It is installed on an ibm t23 laptop.

I know you will ask for more information: plz list the terminal commands to gather the info needed.

Games I have tried and all failed:
Balazar Brothers,
Flight of the Amazon Queen
and several more.

Does Ubuntu have a program that tests and offers to fix a problem?

What additional info do you need to help me? Thank you

Question information

English Edit question
Ubuntu xserver-xorg-video-savage Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Can you give the output of:

sudo uname -a; lsb_release -a; echo; sudo lshw -C display


Revision history for this message
Chuck (chux-industryinet) said :

Output of requested :
Linux T23-3 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:48 UTC 2011 i686 GNU/Linux
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10
Codename: maverick

  *-display UNCLAIMED
       description: VGA compatible controller
       product: SuperSavage IX/C SDR
       vendor: S3 Inc.
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 05
       width: 32 bits
       clock: 66MHz
       capabilities: pm agp agp-2.0 vga_controller bus_master cap_list
       configuration: latency=64 maxlatency=255 mingnt=4
       resources: memory:c0100000-c017ffff memory:e8000000-ebffffff memory:e4000000-e7ffffff memory:e0000000-e1ffffff memory:e2000000-e200ffff

Revision history for this message
actionparsnip (andrew-woodhead666) said :

My help:

Not sure that chip can do 3D accelleration under Linux but that sample xorg.conf may help

Revision history for this message
Chuck (chux-industryinet) said :

I have several ibm t23 computers. The one I'm using now crashes completely back to the first screen after boot up when trying to open 'Eternal Lands' and when running system test. I have not tried any games on the other machines as I seldom play any games.

I assume these games do not work on Ubuntu 10.10 on my machine unless there is something else to try. It seems that the games should not even be listed in 'Ubuntu Software Center' if they don't run on my machine.

If you agree, Thanks for the help and I'll cease the work to correct the problem.

Revision history for this message
Chuck (chux-industryinet) said :

System testing crashes (system-administration-system testing) on video test. It crashes back to the start up screen. Anyone outthere have a clue?

Revision history for this message
Chuck (chux-industryinet) said :

Problem is solved. I removed 10.10 and re-installed 10.01. All is working fine again. Thanx for the help. The problem has been fixed.