low resolution on SIS m671/771 graphic card

Asked by kanhiya on 2010-06-21

currently i have been using ubuntu 10.04, first version that i use was 8.04 and from that time i have been waiting that my graphic card should be automatically detected, i am not a linux professional but i have tried on many forums, spend a lot of time on IRC but result a big zero. I AM NOT ABLE TO GET RESOLUTION GREATER THAN 800X600 and in windows it is working absolutely fine also in SUSE i am able to get resolution 1280x1024 , i have tried many forums,

i want to say that UBUNTU DEVELOPERS have not fixed a problem from last two years. Resolution should be automatically detected.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-savage Edit question
Assignee:
No assignee Edit question
Last query:
2010-06-21
Last reply:
2010-06-21
robinot (robinot) said : #1

suse free or not is german.
your problem means maybe that a simple thing is need : framabook 10.ubuntu

jcglt (jcjglt) said : #2

Here follows my solution to this problem, I cannot say that it will work on your computer, I can only say that it worked well on mine after many attempts to solve it following what I had found on various forums.

Upgrading from Karmic Koala 9.10 to Lucid Lynx 10.04 I faced two graphic card problems :
- resolution limited to 800*600 ;
- no tty nor recovery mode start (unsynchronized display).

1° Resolution :
- download http://dl.dropbox.com/u/983756/sis671_10.x.tar.gz
and http://ajoliveira.com/ajoliveira/gen/bi … .04.tar.gz
uncompress and copy the files from sis671_10.x.tar.gz (xorg.conf in /etc/X11 and the two .so and .la files in /usr/lib/xorg/modules/drivers). The .so and .la files extracted from sis_driver_32-bit_10.04.tar.gz may be even better and could then be copied to replace the two first ones.
Rebooting I got a nice and crisp 1280*800 resolution.

2° Loss of tty and recovery mode
- make sure that the /etc/default/grub file has the two following lines :
        GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
        GRUB_CMDLINE_LINUX=""
There should be NO VGA=XXX (I had it and it was a source of difficulties on my computer)
- in a terminal type the following command lines and execute them one after the other :
        sudo bash (enter your password when requested)
        echo blacklist vga16fb > /etc/modprobe.d/blacklist-vga16fb.conf
        update-initramfs -u
then reboot the computer, mine worked nicely at that time.

BUT this may be harmful as it modifies vital files. I suggest that before doing that you :
- burn a bootable CDROM to be ready to boot your computer on it and be able to undo all modifications done to your vital files ;
- make a copy of those files in their directory and name it for exemple xorg.conf_back, just to be able to restore them if necessary ;
- finally I have my /home mounted on a separate partition, which will make easier a total reinstallation of the system.

Can you help with this problem?

Provide an answer of your own, or ask kanhiya for more information if necessary.

To post a message you must log in.