Blinking login screen after video card driver install

Asked by Byrdman on 2009-11-28

After installing Ubuntu 9.10 on an older system with a GeForce 5500 FX video card, a "restricted" Nvidia driver install (173) was suggested. After activating the driver and allowing it to install, then rebooting the machine, Ubuntu boots up to a blinking login screen. I can't login due to the blinking. How due I resolve this issue? Please assist.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
Byrdman
Solved:
2009-11-28
Last query:
2009-11-28
Last reply:
Omer Akram (om26er) said : #1

here is a qustion: was nvidia driver 173 recommended? now the solution is that you remove the newly installed driver and then reboot this might * might help.: sudo apt-get purge nvidia-glx-173 then reboot.

Omer Akram (om26er) said : #2

and also if that helps then try installing the nvidia driver 180 or 185 this might work

Omer Akram (om26er) said : #3

i forgot to tell you how to get into a shell if you don't already know. press and hold shift after yout bios menu and you will get into a grub menu and then select recovery mode.

Byrdman (byrdman2b) said : #4

Hello and thank you for your help. Which option is recovery mode? When I press shift, I can see nothing but a blank screen. I have a 23 in Acer flat panel. However, when I press enter, it boots back up to the blinking screen - so I obviously can't see the options on the Grub menu. Whic option is the recovery mode? Can I navigate too it using the keyboard?

Byrdman (byrdman2b) said : #5

Hello and thank you for your help.

Which option is recovery mode? When I press shift, I can see nothing but a blank screen. I have a 23 in Acer flat panel. However, when I press enter (after staring at the blank screen like an idiot for a while), it boots back up to the blinking screen - so I obviously can't see the options on the Grub menu. Which option is the recovery mode? Can I navigate too it using the keyboard?

Omer Akram (om26er) said : #6

after going to recovery mode select the first option and it should drop you into a shell i guess and then you can do remove the driver there

Byrdman (byrdman2b) said : #7

I was successful in activating the recovery mode screen, and uninstalling the Nvidia driver from the command prompt. However, it re-booted back to a blinking screen (It blinks even faster now). Should I choose the option to "repair broken packages" from the recovery mode screen?

Omer Akram (om26er) said : #8

connect the internet cable to the computer and then start in recovery mode and there do this
sudo apt-get update && sudo apt-get install nvidia-glx-185

Byrdman (byrdman2b) said : #9

It is installing as I type this (from another machine of course).

Byrdman (byrdman2b) said : #10

Okay - after rebooting (I typed the command "reboot" after the install was done, and the machine went through the process of rebooting) It booted back to the selection screen where you can choose the recovery mode option. Remember - this screen I cannot see for some reason.I had to watch a you tube video to see which direction arrow to push when choosing recovery mode. Anyway, when I press enter - without pressing a direction key, it boots into 9.10 normally - right back to a blinking screen. When I restart, and boot into recovery mode, I see that the 185 driver is there, and I choose the option to resume normal booting (something like that). Well it gets me to a login screen, and I log in. but I'm still in command prompt/shell mode. What now? This is interesting.

Omer Akram (om26er) said : #11

will you plz see at the login screen which session is selected. if its xterm make it gnome.

Byrdman (byrdman2b) said : #12

I thank you for your assistance. It still isn't working properly. However, I'll be taking a different route from here.

Byrdman (byrdman2b) said : #13

Hey, It looks like the video card was malfunctioning. I've got another one in there and things are working fine. Persistence is paying off.