After reseating video card Unity does not start

Asked by wannabeelinux on 2018-04-28

Today I reseated my Nvidia video card after cleaning out dust of the several fans my media pc has (about 4 of them). The pc was making more noise than I like so I thought that that would make the noise go away, and it did. Sadly, after reseating my videocard the desktop of Unity will not load. I can see the start menu and I am able to start recovery mode.

The Unity desktop does load with this workaround:
Choose recovery mode, choos dpkg option, do all steps this mode requires and then choose resume. After that, my desktop load automatically (It does automatic login).

My details are:
System:
#44~16.04.1-Ubuntu SMP Thu Apr 5 16:43:10 UTC 2018

Videocard:
sudo lshw -C display
[sudo] wachtwoord voor media:
  *-display
       description: VGA compatible controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:125 memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:c0000-dffff

The videodriver I use is
Nvidia binary driver - version 384.130 (open-source version).

resetting Unity did not save me this time, nor removing .config directory.

Any help would be very much appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
wannabeelinux
Solved:
2018-05-04
Last query:
2018-05-04
Last reply:
wannabeelinux (bas-douma) said : #1

When booting the normal way, my system does a disk check up front and after that I see I screen with the word Ubuntu and the progress dots. When the check is at 95 % only the word Ubuntu and 5 red dots are to be seen.The light of hard disk activity is burning continually.

BTW: I use two disks, one SSD which holds ubuntu and one SATA which hold my home folder.

wannabeelinux (bas-douma) said : #2

Finally I found what is going on. My stepson had started the pc the screen was filled whith the same message that stated that the system had found an inconsistency in / on /dev/sb1. Before I go on I should explain that this pc used to run ubuntu 14 from this disk while at the moment in runs ubuntu 16 from another disk named /dev/sdba1. The grub menu shows both systems though ubuntu 14 has never run well after adding a second disk and installing ubuntu 16 after replacing the motherboard and video card (which makes kind of sense as well). I reconfigured the Ubuntu 16 system to use the swap partition and home of the ubuntu 14 disk so I could save money on buying a small SSD disk for ubuntu 16 and save time when installing ubuntu 16 because I did not need to restore any data (I think any media pc has a lot of data for music, photo's and home made video's and gaming data).

So I think that to solve this issue I need to remove the Ubuntu 14 installation entirely from the second disk and remove the entry from the grub menu. It will take me some time to figure that out so when I have solved it I will get back here, unless someone has a suggestion on how to go about this.

wannabeelinux (bas-douma) said : #3

Whoops, in the process of cleaning up the old ubuntu I have removed my whole /etc directory instead of the old etc directory of the old ubuntu 14 install on my second disk. And because of a lack of proper backup I now see no other quick solution than to install ubuntu 16 again on this pc.